Emails not firing when build fails

Hello,

I have managed to get TeamCity up and running and can see any change committed in SVN, building in TeamCity but for some reason, its not firing emails when code breaks.

I have setup an 'Email Notifier' where Watch points to 'Builds from project' and send notofication when points to 'Build fails'. In server Administration --> Email Notifier, I have given SMTP Host, Port etc and have also tested the connection (which comes as successful).

First question is, when i test this connection giving my email address and gives me 'connection succesful'. should i expect some kind of email from TeamCity as test or it doesnt send any email and just tests the connection?

Second, why doesnt it fire emails when build fails?

Any help will be appreciated.

Thanks

3 comments
Comment actions Permalink
Hi Jay I do not recall that the test connection generates an email. I think your best approach is to check the teamcity-server log to see if the email was generated, and to check the SMTP server logs, to see why it did not send the email (in case it actually received it). cheers  ziv shapira
0
Comment actions Permalink

Hi Ziv,

I have checked my server log and their is no entry of anything when i test my connection, can you suggest somewhere else i should look.

Thanks
Jay

0
Comment actions Permalink
that is because i don't think a test connection tries to send an email (as I wrote). You should check the teamcity server logs AND the SMTP server logs, after a job failure.   Are there other emails arrving at all? If not, make a job configuration with a command line step, that just sends a mail (e.g. sendmail in linux) to see the problem.
0

Please sign in to leave a comment.