Team City Migration to MSSQL

Hi,

We are running team city 7.1.1. We were using the internal database. I migrated it to the SQL Server through the MaintainDB tool. When I first ran the tool, it complained that it cannot find java.exe. So I downloaded and installed the latest available java on the server and installed the jTDS driver(http://jtds.sourceforge.net/) as mentioned in the documentation.

But when I start the team city server back on, I get an error on start up."No suitable JDBC driver found for database type: MSSQL"


The logs look like this:
[2012-11-02 14:41:51,513]   INFO -   jetbrains.buildServer.SERVER - Starting TeamCity server
[2012-11-02 14:41:51,684]   INFO -   jetbrains.buildServer.SERVER - TeamCity version: 7.1.1 (build 24074), data format version 544
[2012-11-02 14:41:52,513]   INFO -  jetbrains.buildServer.STARTUP - Servlet real path: c:\TeamCity\bin\..\webapps\ROOT\
[2012-11-02 14:41:52,528]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Looking for the TeamCity Data Directory
[2012-11-02 14:41:52,528]   INFO -  jetbrains.buildServer.STARTUP - TeamCity Data Directory path is determined using the environment variable TEAMCITY_DATA_PATH
[2012-11-02 14:41:52,528]   INFO -  jetbrains.buildServer.STARTUP - Data Directory C:\TeamCity\.BuildServer exists
[2012-11-02 14:41:52,606]   INFO -  jetbrains.buildServer.STARTUP - The main configuration file exists
[2012-11-02 14:41:52,606]   INFO -  jetbrains.buildServer.STARTUP - The database properties file exists
[2012-11-02 14:41:52,669]   INFO -  jetbrains.buildServer.STARTUP - The internal database data file exists
[2012-11-02 14:41:52,825]   INFO -  jetbrains.buildServer.STARTUP - Data Directory version: 544
[2012-11-02 14:41:52,825]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Looking for the database configuration
[2012-11-02 14:41:52,825]   INFO -  jetbrains.buildServer.STARTUP - Database properties file (C:\TeamCity\.BuildServer\config\database.properties) exists
[2012-11-02 14:41:52,825]   INFO -  jetbrains.buildServer.STARTUP - Internal HSQL database file (C:\TeamCity\.BuildServer\system\buildserver.data) exists
[2012-11-02 14:41:52,950]   INFO -  jetbrains.buildServer.STARTUP - Database connection URL: jdbc:jtds:sqlserver://DEV:1433/TeamCity;instance=SQL2012
[2012-11-02 14:41:52,950]   INFO -  jetbrains.buildServer.STARTUP - Using database connection URL from the database properties file. The URL is: jdbc:jtds:sqlserver://DEV:1433/TeamCity;instance=SQL2012
[2012-11-02 14:41:52,950]   INFO -  jetbrains.buildServer.STARTUP - Using external (MSSQL) database
[2012-11-02 14:41:52,950]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Connecting to the database
[2012-11-02 14:41:52,950]   INFO -  jetbrains.buildServer.STARTUP - Loading JDBC drivers
[2012-11-02 14:41:53,028]   WARN -   jetbrains.buildServer.SERVER - Unable to load JDBC driver class: net.sourceforge.jtds.jdbc.Driver, due to exception: java.lang.UnsupportedClassVersionError: net/sourceforge/jtds/jdbc/Driver : Unsupported major.minor version 51.0
[2012-11-02 14:41:53,763]  ERROR -  jetbrains.buildServer.STARTUP - No suitable JDBC driver found for database type: MSSQL

[2012-11-02 14:41:53,763]   INFO -  jetbrains.buildServer.STARTUP - Current stage: TeamCity server startup error  

With the JTDS Driver(http://jtds.sourceforge.net/), the import to the Database is successful.  Is this looking for some other driver?
I installed the latest version of Java.
Looking at the Message ": Unsupported major.minor version 51.0 ", do I have a wrong version of Java?

3 comments
Comment actions Permalink

Hi,

I stumbled across this thread as I have today been having the exact same problem as you, fortunately, I have fixed it, are you still having the problem?
The guide I followed to setup my SQL Server database and connection told me to download the latest jTDS driver. I noticed that the guide was written in Aug 2009 so I downloaded the driver prior to that guide being written and used that. Version 1.2.2 worked for me but I had to add it into my build config directory (in my case was %Drive%\ProgramData\JetBrains\TeamCity\lib\jdbc)

Try that, restart TeamCity server and fingers crossed!

0
Comment actions Permalink

Version 1.2.2 was the fix for me.  Thanks!!!

0
Comment actions Permalink

I had the same issue, only I had grabbed the latest 1.3 of jtds. Apparently that uses Java 7, and my TeamCity isn't running under that. Running the latest pre-1.3 worked for me.

0

Please sign in to leave a comment.