Problem installing TeamCity 8.0 on ubuntu 12.10

Hi,

I downloaded TeamCity-8.0.tar.gz on an unbuntu 12.10 vm, unpacked the archive and launched it with the `TeamCity/bin/runall.sh start` command. I was able to connect to port 8111 which asked me to click a couple of buttons and then it went to a page saying "

TeamCity is starting

Initializing TeamCity server components

This page will be reloaded automatically as soon as TeamCity is ready.

TeamCity 8.0 (build 27402)

"

This hangs and eventually goes to a dead page. On the server side, I get:

$ TeamCity/bin/runAll.sh start
Using CATALINA_BASE:   /home/me/TeamCity
Using CATALINA_HOME:   /home/me/TeamCity
Using CATALINA_TMPDIR: /home/me/TeamCity/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /home/me/TeamCity/bin/bootstrap.jar:/home/me/TeamCity/bin/tomcat-juli.jar
Starting TeamCity build agent...
Java executable is found in '/usr/bin/..'.
Starting TeamCity Build Agent Launcher...
Agent home directory is /home/me/TeamCity/buildAgent
Current Java runtime version is 1.6
Lock file: /home/me/TeamCity/buildAgent/logs/buildAgent.properties.lock
Using no lock
Done [9912], see log at /home/me/TeamCity/buildAgent/logs/teamcity-agent.log


That log says:

[2013-06-25 22:10:31,506]   INFO - s.buildServer.agent.AgentMain2 - ===========================================================
[2013-06-25 22:10:31,580]   INFO - s.buildServer.agent.AgentMain2 - TeamCity Build Agent 8.0 (build 27402), OS: Linux, JRE: 1.6.0_27-b27
[2013-06-25 22:10:31,580]   INFO - s.buildServer.agent.AgentMain2 - Starting...
[2013-06-25 22:10:31,585]   INFO - s.buildServer.agent.AgentMain2 - Agent home is /home/me/TeamCity/buildAgent
[2013-06-25 22:10:32,057]   INFO - buildServer.agent.AgentMain2$2 - Refreshing jetbrains.buildServer.agent.AgentMain2$2@10ad8659: startup date [Tue Jun 25 22:10:32 UTC 2013]; root of context hierarchy
[2013-06-25 22:10:44,640]   WARN -    jetbrains.buildServer.AGENT - Calculating CPU benchmark index...
[2013-06-25 22:10:53,035]   WARN -    jetbrains.buildServer.AGENT - CPU benchmark index is set to 378
[2013-06-25 22:10:53,696]   INFO - dAgentConfigurationInitializer - Loading build agent configuration from ../conf/buildAgent.properties
[2013-06-25 22:10:54,393]   INFO - rver.plugins.PluginManagerImpl - ===========================================================
[2013-06-25 22:10:54,418]   INFO - rver.plugins.PluginManagerImpl - Plugins initialization started...
[2013-06-25 22:10:54,419]   INFO - rver.plugins.PluginManagerImpl - Scanning plugins folders
[2013-06-25 22:10:54,452]   INFO - ctories.CleanupRegistryCleaner - Removing files from .old to meet free space requirements.
[2013-06-25 22:10:54,454]   INFO - .plugins.files.JarSearcherBase - Scanning plugin folder: /home/me/TeamCity/buildAgent/plugins
[2013-06-25 22:10:54,551]   INFO - .plugins.files.JarSearcherBase - Scanning plugin folder: /home/me/TeamCity/buildAgent/tools
[2013-06-25 22:10:54,651]   INFO - rver.plugins.PluginManagerImpl - Found 1 plugins: [amazonEC2]
[2013-06-25 22:10:54,654]   INFO - rver.plugins.PluginsCollection - No plugins were loaded with standalone classloaders
[2013-06-25 22:10:54,654]   INFO - rver.plugins.PluginsCollection - Load shared classloader for 1 plugins [amazonEC2]
[2013-06-25 22:10:56,740]   INFO - rver.plugins.PluginManagerImpl - Plugins initialization completed:
[2013-06-25 22:10:56,835]   INFO - rver.plugins.PluginManagerImpl - Loaded 1 plugins: [amazonEC2]
[2013-06-25 22:10:56,836]   INFO - rver.plugins.PluginManagerImpl - ===========================================================
[2013-06-25 22:10:56,896]   INFO -    jetbrains.buildServer.AGENT - Build Agent version: 27402, plugins signature: NA
[2013-06-25 22:10:56,985]   INFO - dAgentConfigurationInitializer - Loading build agent configuration from ../conf/buildAgent.properties
[2013-06-25 22:11:07,938]   INFO - t.AmazonInstanceMetadataReader - Amazon is not available. Amazon EC2 integration is not active: Failed to connect to http://169.254.169.254/2009-04-04. The host did not accept the connection within timeout of 7000 ms
[2013-06-25 22:11:07,977]   INFO - .agent.AmazonPropertiesUpdater - Fetched AmazonEC2 instance metadata:  
[2013-06-25 22:11:08,035]   INFO - zon.agent.AmazonMetadataChecks - Amazon EC instance metadata contains no keys
[2013-06-25 22:11:08,035]   WARN - .agent.AmazonPropertiesUpdater - Fetched Amazon EC2 instance metadata does not contain required values. Probably this agent was not started inside Amazon EC2. Is proxy server used?
[2013-06-25 22:11:10,435]   INFO -    jetbrains.buildServer.AGENT - Start build agent
[2013-06-25 22:11:11,415]   INFO -    jetbrains.buildServer.AGENT - Agent Web server started
[2013-06-25 22:11:11,594]   INFO - agent.impl.AgentDetailsFactory - Build agent ownAddress will be defined by the server. Define 'ownAddress' property in the conf/buildAgent.properties file
[2013-06-25 22:11:11,753]   INFO - ctories.CleanupRegistryCleaner - Removing files from .old to meet free space requirements.
[2013-06-25 22:11:13,705]   INFO - buildServer.AGENT.registration - Registering on server http://localhost:8111, AgentDetails{Name='Default Agent', AgentId=null, BuildId=null, AgentOwnAddress='null', AlternativeAddresses=[184.106.225.245, 10.179.170.132], Port=9090, Version='27402', PluginsVersion='NA', AvailableRunners=[], AvailableVcs=[], AuthorizationToken=''}
[2013-06-25 22:11:26,478]   INFO - l.directories.DirectoryMapImpl - Cleaning up old checkout directories. Default lifetime = 192 hour(s)
[2013-06-25 22:11:29,662]   INFO - agent.impl.AgentPortFileWriter - Writing agent runtime file to /home/me/TeamCity/buildAgent/bin/../logs/buildAgent.port
[2013-06-25 22:11:29,672]   INFO - agent.impl.AgentPortFileWriter - Launcher version is 27402
[2013-06-25 22:11:29,672]   INFO - agent.impl.AgentPortFileWriter - Writing agent runtime file to /home/me/TeamCity/buildAgent/bin/../logs/buildAgent.port :DONE!
[2013-06-25 22:11:30,147]   INFO -    jetbrains.buildServer.AGENT - Build agent started
[2013-06-25 22:11:31,724]   WARN - buildServer.AGENT.registration - Call http://localhost:8111/RPC2 buildServer.registerAgent3: java.io.IOException: Server returned status 503 (service unavailable), try later
[2013-06-25 22:11:31,731]   WARN - buildServer.AGENT.registration - Connection to TeamCity server is probably lost. Will be trying to restore it. Take a look at logs/teamcity-agent.log for details (unless you're using custom logging).


There is no logs/teamcity-agent.log file.

What next?
3 comments
Comment actions Permalink

Hi Matthew

TeamCity starts two processes - a web server and a build agent. The log from the agent is fine, but issues you have are at server side.
Could you please post teamcity-server.log file.

0
Comment actions Permalink

Here's my log - sorry the timestamps don't match, but this is with the identical symptoms.

[2013-06-27 09:39:25,089]   INFO -  jetbrains.buildServer.STARTUP -






[2013-06-27 09:39:25,090]   INFO -  jetbrains.buildServer.STARTUP - ===========================================================
[2013-06-27 09:39:25,090]   INFO -  jetbrains.buildServer.STARTUP - Starting TeamCity server
[2013-06-27 09:39:27,481]   INFO -  jetbrains.buildServer.STARTUP - TeamCity version: 8.0 (build 27402), data format version 628
[2013-06-27 09:39:27,535]   INFO -  jetbrains.buildServer.STARTUP - OS: Linux, JRE: 1.6.0_27-b27
[2013-06-27 09:39:27,536]   INFO -  jetbrains.buildServer.STARTUP - Servlet real path: /home/me/TeamCity/webapps/ROOT/
[2013-06-27 09:39:27,561]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Looking for the TeamCity Data Directory
[2013-06-27 09:39:27,562]   INFO -  jetbrains.buildServer.STARTUP - TeamCity Data Directory path is determined using the user home directory
[2013-06-27 09:39:27,562]   INFO -  jetbrains.buildServer.STARTUP - Data Directory "/home/me/.BuildServer" exists
[2013-06-27 09:39:28,242]   INFO -  jetbrains.buildServer.STARTUP - The main configuration file "/home/me/.BuildServer/config/main-config.xml" exists
[2013-06-27 09:39:28,242]   INFO -  jetbrains.buildServer.STARTUP - The database properties file "/home/me/.BuildServer/config/database.properties" doesn't exist
[2013-06-27 09:39:28,242]   INFO -  jetbrains.buildServer.STARTUP - The internal database data file "/home/me/.BuildServer/system/buildserver.data" exists
[2013-06-27 09:39:28,585]   INFO -  jetbrains.buildServer.STARTUP - Data Directory version: 628
[2013-06-27 09:39:28,585]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Looking for the database configuration
[2013-06-27 09:39:28,585]   INFO -  jetbrains.buildServer.STARTUP - Database properties file "/home/me/.BuildServer/config/database.properties" doesn't exist
[2013-06-27 09:39:28,585]   INFO -  jetbrains.buildServer.STARTUP - Internal HSQL database file (/home/me/.BuildServer/system/buildserver.data) exists, version: 2.2.9
[2013-06-27 09:39:28,594]   INFO -  jetbrains.buildServer.STARTUP - Using internal (HSQL) database
[2013-06-27 09:39:28,595]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Connecting to the database
[2013-06-27 09:39:35,136]   INFO -  jetbrains.buildServer.STARTUP - Connected to the database successfully
[2013-06-27 09:39:35,140]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Checking the database
[2013-06-27 09:39:35,187]   INFO -  jetbrains.buildServer.STARTUP - Using schema: PUBLIC
[2013-06-27 09:39:35,246]   INFO -  jetbrains.buildServer.STARTUP - Schema contains 120 tables.
[2013-06-27 09:39:35,277]   INFO -  jetbrains.buildServer.STARTUP - Database version is 628
[2013-06-27 09:39:35,277]   INFO - ide.db.TeamCityDatabaseManager - Attempt to capture TeamCity DB lock (java thread 16, starting code 155780448, attempt 1)
[2013-06-27 09:39:35,278]   INFO - ide.db.TeamCityDatabaseManager - The TeamCity DB lock has been captured successfully (java thread 16, starting code 155780448, attempt 1)
[2013-06-27 09:39:35,349]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Initializing TeamCity server components
[2013-06-27 09:39:35,489]   INFO -  jetbrains.buildServer.STARTUP - Starting the main application
[2013-06-27 09:39:36,097]   INFO - ebDispatcherApplicationContext - Refreshing jetbrains.buildServer.maintenance.WebDispatcherApplicationContext@214b4b3a: startup date [Thu Jun 27 09:39:36 UTC 2013]; root of context hierarchy
[2013-06-27 09:39:36,382]   INFO - MainTeamCityApplicationContext - Refreshing WebApplicationContext for namespace 'buildServer-servlet': startup date [Thu Jun 27 09:39:36 UTC 2013]; parent: jetbrains.buildServer.maintenance.WebDispatcherApplicationContext@214b4b3a

[2013-06-27 09:41:10,946]   INFO -   jetbrains.buildServer.SERVER - Loading test names index from database...
[2013-06-27 09:41:17,659]   INFO -   jetbrains.buildServer.SERVER - Finished loading test names index
[2013-06-27 09:41:27,123]   INFO -   jetbrains.buildServer.SERVER - Start initializing build durations cache...
[2013-06-27 09:41:27,889]   INFO -   jetbrains.buildServer.SERVER - Finished initializing build durations cache
[2013-06-27 09:43:35,099]   INFO -   jetbrains.buildServer.SERVER - Loading roles from the configuration file: /home/me/.BuildServer/config/roles-config.xml


It all seems to hang about here.I've given it 30 minutes and no more output.
0
Comment actions Permalink

Any hints? I've just come back to this after a week or so doing other things.

0

Please sign in to leave a comment.