teamcity-vcs.log message issue

Hi,

I could not get few messages in teamcity-vcs.log file after changing Perforce server from one to another.

The example of the message which I am talking about is following ( which TeamCity writes in log file after collecting changes from VCS) :


[2012-11-02 14:13:19,890]   INFO [7, parent id=4}] -      jetbrains.buildServer.VCS - Finish collecting changes for perforce: perforce:1666 {instance id=17, parent id=4} from state SingleVersionRState{389052 at Fri Nov 02 14:13:19 EDT 2012} to state SingleVersionRState{389053 at Fri Nov 02 14:13:19 EDT 2012}; 0 changes collected 0 changes reported, time spent: 37ms


The new Perforce server is running in windows-7 machine and TeamCity is running in Debian. Everything else works fine with new setup. TeamCity is detecting changes from Perforce server and triggering builds normally. The only thing is I am not getting is log message in VCS log file which is important to me.

In addition, I am getting following warnings when I restart the TeamCity Server:


[2012-11-07 15:05:34,026]   INFO [TeamCityStartup] -      jetbrains.buildServer.VCS - Server-wide hg path is not set, will use path from the VCS root settings
[2012-11-07 15:05:36,053]   WARN [TeamCityStartup] - ldTriggers.vcs.vss.VssSupport2 - Unable to run SourceSafe Support under non-windows OS


I hope someone can easily guess what is going wrong with this configuration.

Thanks in advance.

Sobit Thapa

1 comment
Comment actions Permalink

Hi Sobit,

were you able to relsove the issue mentioned in your dicussion.

ldTriggers.vcs.vss.VssSupport2 - Unable to run SourceSafe Support under non-windows OS

I am facing the same on one of our teamcity installations

0

Please sign in to leave a comment.