0

TeamCity after upgrade hangs on Connecting to the database

Hi,

I have small installation of TeamCity 7.1.5 with Postgres DB running on the same host. Today I've upgraded TeamCity to version 8.0.2 (Linux host, tgz file unpacked to the current teamcity directory). After start of TeamCity in web browser I can see message "Connecting to the database" but it hangs on it. Here is a teamcity-server log:

[2013-08-19 12:35:32,843]   INFO -  jetbrains.buildServer.STARTUP - ===========================================================
[2013-08-19 12:35:32,843]   INFO -  jetbrains.buildServer.STARTUP - Starting TeamCity server
[2013-08-19 12:35:34,380]   INFO -  jetbrains.buildServer.STARTUP - TeamCity version: 8.0.2 (build 27482), data format version 628
[2013-08-19 12:35:34,553]   INFO -  jetbrains.buildServer.STARTUP - OS: Linux, JRE: 1.6.0_26-b03
[2013-08-19 12:35:34,561]   INFO -  jetbrains.buildServer.STARTUP - Servlet real path: /opt/TeamCity/webapps/ROOT/
[2013-08-19 12:35:34,562]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Looking for the TeamCity Data Directory
[2013-08-19 12:35:34,562]   INFO -  jetbrains.buildServer.STARTUP - TeamCity Data Directory path is determined using the environment variable TEAMCITY_DATA_PATH
[2013-08-19 12:35:34,562]   INFO -  jetbrains.buildServer.STARTUP - Data Directory "/root/.BuildServer" exists
[2013-08-19 12:35:35,570]   INFO -  jetbrains.buildServer.STARTUP - The main configuration file "/root/.BuildServer/config/main-config.xml" exists
[2013-08-19 12:35:35,570]   INFO -  jetbrains.buildServer.STARTUP - The database properties file "/root/.BuildServer/config/database.properties" exists
[2013-08-19 12:35:35,570]   INFO -  jetbrains.buildServer.STARTUP - The internal database data file "/root/.BuildServer/system/buildserver.data" doesn't exist
[2013-08-19 12:35:36,154]   INFO -  jetbrains.buildServer.STARTUP - Data Directory version: 544
[2013-08-19 12:35:36,154]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Looking for the database configuration
[2013-08-19 12:35:36,154]   INFO -  jetbrains.buildServer.STARTUP - Database properties file "/root/.BuildServer/config/database.properties" exists
[2013-08-19 12:35:36,155]   INFO -  jetbrains.buildServer.STARTUP - Internal HSQL database file (/root/.BuildServer/system/buildserver.data) doesn't exist
[2013-08-19 12:35:36,188]   INFO -  jetbrains.buildServer.STARTUP - Database connection URL: jdbc:postgresql://127.0.0.1/teamcity
[2013-08-19 12:35:36,188]   INFO -  jetbrains.buildServer.STARTUP - Using database connection URL from the database properties file. The URL is: jdbc:postgresql://127.0.0.1/teamcity
[2013-08-19 12:35:36,188]   INFO -  jetbrains.buildServer.STARTUP - Using external (POSTGRESQL) database
[2013-08-19 12:35:36,188]   INFO -  jetbrains.buildServer.STARTUP - Current stage: Connecting to the database


According to the database there is no connection from TeamCity. Database seems running OK. It's Postgres 9.1.4. Any idea how can I fix this issue?

2 comments

Please sign in to leave a comment.