TeamCity not detecting changes in my SCM for one user.

TeamCity Professional 7.1.5 (build 24400)
Windows 2008 R2


My SCM is Surround SCM version 2013.0.0

I have a build server up and running and it was seemingly working flawlessly- for me. I configured a Build config to check Surround, it was triggering builds and everything was happy. I even had my FinalBuilder build project rollback files that failed a build using an automation account in Surround.

TeamCity detected file changes for both my Surround account and the automation account.

But when I had one of the developers try to make a change on the branch/repository- it did not detect his changes.

I do have LDAP configured- and so far the other developer and I are the only two users in TeamCity.

My user account is the admin in TeamCity, but the developer's is not. But the Automation account in Surround doesn't even have an account in TeamCity and TC detected the changes it made (on rollbacks).


Is there some congfiguration I am missing here?
2 comments
Comment actions Permalink

UPDATE.

Another commonality between my account in Surround and the AUtomation account was that we are both Admins in Surround. So I removed myself from the admin acoutn and tried triggering a build. It still worked.

I also had 2 other developers (with no user accounts in TC, and NOT admins in Surround) check-in files to the branch in Surround and they both triggered the build in TC.

At this point- I am thinking it may be related to LDAP? For some reason- my LDAP is working and the 1st user isn't? When he first went to our TC site- he entererd his Windows Username and Password and it created an account for him. But I noticed on his screen that he was gettign a message saying that TeamCity couldn't read the VCS with his TC credentials. I am not sure how that is since Surround is integrated with LDAP also. And I am not having a problem with it.  

Any ideas?

0
Comment actions Permalink

UPDATE 2

I think this may be an issue with the Surround Plug-in for TeamCity.

I was able to get about 4 other users to trigger builds in Surround. The thing that stood out to me about the one user who couldn't was that his login name was long. Not super long, but longer than the others.

So I did a small test:

Users whose login is <=13 characters can all trigger builds from Surround.

Users whose login is >=14 characters can NOT trigger builds from Surround.

I hope this is an issue with the plugin because I'm guessing Seapine can fix that.

0

Please sign in to leave a comment.