Compilation Error C# Class Library

So I have build project on TeamCity 8.0.3 and have create two build steps.

1.) The first step is to Install all NuGet packages.
I have set my project up according to http://jamesheppinstall.wordpress.com/2012/05/15/dependency-management-in-net-with-nuget-and-teamcity/ blog and if I run this step it works fine however I went over the logs and found:  `All packages listed in packages.config are already installed.` Is this OK?

2.) I have another step that is suppose to build my Class Library however I get a compilation error saying that references are missing even after step one, which is suppose to install the packages, has passed?

I am using Visual Studio 2012.

What am I doing wrong here?
Please let me know if I must add more detail!

2 comments
Comment actions Permalink

Hi Michael

"All packages are installed" message is absolutely fine. Sources and packages are reused between the builds. The dependencies were successfully downloaded in a previous build.

I suspect this issue should be reproduced even without TeamCity.
Go to TeamCity build agent machine, open the checkout directory (you can find the path in start of build log), and run MSBuild from there manually.

Let me know results.

0
Comment actions Permalink

Thanks for the response, I recreated the project in Visual Studio and everything worked fine!

0

Please sign in to leave a comment.