Agent Install Failure

I'm trying to push an agent to a local VM and am seeing the following.  Any thoughts would be appreciated.  I've verified I can login to the machine fine.

[09:22:54]: AgentPush v27616 - Install Agent on remote host
[09:22:54]: Looking for Target Host...
[09:22:54]: Validating TeamCity Server Root URL 'http://fmpdmb.part.net:8111' ...
[09:22:54]: Starting agent push to 'curufin'(IP:  172.16.28.189) using preset 'default' (Username 'cfgmgr'. Target  platform: 'Unix')
[09:22:54]: Checking Platform...
[09:22:57]: bash: sw_vers: command not found
[09:22:59]: Linux curufin 3.2.0-55-generic #85-Ubuntu SMP Wed Oct 2 12:29:27 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[09:23:01]: Detected Platform: Linux (Linux curufin  3.2.0-55-generic #85-Ubuntu SMP Wed Oct 2 12:29:27 UTC 2013 x86_64  x86_64 x86_64 GNU/Linux)
[09:23:01]: Determining installation path...
[09:23:01]: SHLVL=1
[09:23:01]: _=/usr/bin/env
[09:23:03]: The Agent will be installed to /home/cfgmgr/BuildAgent on 'curufin'
[09:23:03]: Uploading installation script bootstrapper.sh into remote directory /home/cfgmgr/BuildAgent ...
[09:23:05]: 4: Received message is too long: 1112686921
[09:23:06]: chmod: cannot access `./bootstrapper.sh': No such file or directory
[09:23:08]: Remote  agent installation failed: Command '[chmod +x ./bootstrapper.sh]' was  executed with error message(s): chmod: cannot access  `./bootstrapper.sh': No such file or directory

The last 3 lines are red.

After attempting to push the agent, the BuildAgent directory also doesn't exist.  This feels like a permission issue, but the user I'm logging in as (cfgmgr) owns the directory I'm trying to install to (/home/cfgmgr/BuildAgent).

1 comment
Comment actions Permalink

Lame! I figured it out... I had some echo statements in my .bashrc file that were
confusing the ftp process or something.  Commenting these statements out has resolved the i
ssue.


0

Please sign in to leave a comment.