Changing TFS command parameters namely removing /noProxy

Hi

So after many hours of trial/error and research, I finally worked out why I could not connect to TFS preview (Hosted TFS) - the /noProxy command being used in TeamCity. I ran the following on the command line:


C:\TeamCity\webapps\ROOT\WEB-INF\plugins\tfs\bin\tfs-native.exe https://servername.visualstudio.com/DefaultCollection /user:username /hash:S  C:\TeamCity\temp\TC-GM.result GetCurrentVersion $/path

And I got a successful response.

Then I ran the same command with the /noProxy included and that displayed the error I get on the TeamCity UI:  - ERROR - TF400324: Team Foundation services are not available from server servername.visualstudio.com\DefaultCollection.

C:\TeamCity\webapps\ROOT\WEB-INF\plugins\tfs\bin\tfs-native.exe https://servername.visualstudio.com/DefaultCollection /user:username /hash:S /noProxy C:\TeamCity\temp\TC-GM.result GetCurrentVersion $/path.

I have already set my company proxy settings using the TEAMCITY_SERVER_OPTS environment variable.


So my question is, is there a way that I can run TFS without the /noProxy parameter?

Thanks in advance.

3 comments
Comment actions Permalink

Just a bit of an update. After more reading on JetBrains forum I came across this post:

http://devnet.jetbrains.com/message/5493754#5493754 (Tfs not working after update to 8.0.2 (build 27482)

This led me to downgrade back to version 8.0 (Build: 27402) from 8.0.5 and that resolved the issue with the connection to TFS. However, I decided to go a step further and I took a copy of the contents of the tfs plugin folder (C:\TeamCity\webapps\ROOT\WEB-INF\plugins\tfs) from 8.0, re-upgraded TeamCity to 8.0.5, backed up the 8.0.5 version of tfs plugin folder and then replaced it with the 8.0 version.

That also appears to be working, so as a short term solution I will continue in this manner.

If anyone comes up with a better solution, please do post it up.

0
Comment actions Permalink

Please try setting 'teamcity.tfs.useSystemProxy=true' internal property to make TFS work via proxy.
http://confluence.jetbrains.com/display/TCD6/Configuring+TeamCity+Server+Startup+Properties

0
Comment actions Permalink

Hi Eugene

That property worked with the latest tfs plugin (8.0.5), I can now successfully use tfs.

Thank you very much!

Gav

0

Please sign in to leave a comment.