Unable to pass configuration values when starting build via HTTP

I have been reading about the REST API while trying to figure out how to kick off a build via HTTP. After reading Accessing Server by HTTP I was able to start a build. However, when I pass in a configuration parameter's value it isn't being applied to my build. Is there something wrong with my syntax? Is there a alternate/better way to start this build via HTTP? This is a configuration value and it is the full property name. Here's part of the URL I am using:

/httpAuth/action.html?add2Queue=bt30&name=tagName&value=testing

When viewing the Build Parameters in the build history I see the default value for tagName instead of testing.

I'm using TeamCity Professional 7.1.1 (build 24074).

5 comments
Comment actions Permalink

This still isn't working for me in 8.0.4 27616. Can anyone else successfully pass configuration values?

0
Comment actions Permalink

I've tested your string, and it works successfully.
Can you post a screenshot of the build history page where you check the results?
Is the parameter accessible inside the build script? For example you can rename it to env.tagName and use command-line runner with echo %TAGNAME% command. What is in the build log?

0
Comment actions Permalink

Hi Michael,

Thanks for looking into this. The parameter is also blank inside the build script. When specified via the run custom build UI it is passed correctly. Here's the screenshot. I am in the administrators group.

Untitled.png

0
Comment actions Permalink

How do you make this HTTP call? Is the URL string quoted?

0
Comment actions Permalink

With fiddler on windows. I did some more testing and was able to see some configuration parameters correctly being sent/used. Configuration parameters whose type is text/hidden that I send in are not being applied.

0

Please sign in to leave a comment.