Stuck in maintenance mode

Hi hope this is right place for this query ..

I recently installed the latest version of TeamCity and after changing the user the service was running at .. I got an IO Exception on the buildserver.lck file .. after resolving the user permissions issue .. I tried removing the buildserver.lck file but was still stuck in maintenance mode .. I've managed to backup the database and now restore it to SQL server ... ( all seemed to go ok .. )  but I'm still stuck in matainence mode with the same error .. I completely cleared the system dir ( as per the instructions re the 'connecting to an external database')  but I'm still getting the io error on the buildserver.lck file ...

PS .. the teamcirty-server.log does not contain a maintenance token!

Where is this 'maintenance mode' state stored? How can I break out of maintenance mode?

4 comments
Comment actions Permalink

Maintenance token is written in both - process stdfout and teamcity-server.log. If you start TeamCity from command line via teamcity-server.bat or teamcity-server.sh, you should token in console. The reason why the token is not logged in teamcity-server.log could be related to insufficient permissions. I'd check that server user can write to the log file.

0
Comment actions Permalink

Hi the service has permissions to write to the log .. I can see entries relating to the service starting up and then stopping a few moments later ..
but there is no maintenance token in there ..

re my previous question .. where is the state that puts the database in maintenance mode kept ? I have full access to the sql database and filesystem .. I'd just like to clear the maintenance mode and get the build server running again asap


cheers
Matt

0
Comment actions Permalink

I don't think hacking the database is a good idea, we need to find the cause of the issue first. Could you please attach teamcity-server.log file?

0
Comment actions Permalink

It seems a reboot fixed the problem ... (last thing I did before I went home was to reboot the server )

problems started
[2013-11-28 16:03:56,301] when I changed the user that the service was running as
things I tried:
I changed the user back to the previous user  
I deleted the buildserver.lck file
I migrated the database to SQL server
the problem still peristed .
[2013-11-28 18:05:53,214] I rebooted the server and it came back up ...



Attachment(s):
teamcity-server.log.zip
0

Please sign in to leave a comment.