My junit test always ignored

Hello,

     I'm new to TeamCity. I have a very basic setup:

one build step which has a command line runner. This runner runs a script that generates a xml report in junit format.
This report is then parsed by the XML report processing build feature (Ant JUnit).

When build finishes, I go to Test tab and I can see my test has been ignored, why is that? Please, I would appreciate some help.

This is my complete log:

[17:33:31]Skip checking for changes - there are no VCS roots defined
[17:33:31]Ant JUnit report watcher
[17:33:31][Ant JUnit report watcher] Watching paths:
[17:33:31][Ant JUnit report watcher] C:\TeamCity\buildAgent\work\f93452fdf52dbc98\homepage.yslow-38.xml
[17:33:31]Publishing internal artifacts (1s)
[17:33:32][Publishing internal artifacts] Sending build.start.properties.gz file
[17:33:31]Clearing temporary directory: C:\TeamCity\buildAgent\temp\buildTmp
[17:33:31]Checkout directory: C:\TeamCity\buildAgent\work\f93452fdf52dbc98
[17:33:31]Step 1/1: Command Line (34s)
[17:33:31][Step 1/1] Starting: C:\TeamCity\buildAgent\temp\agentTmp\custom_script4145448001271194801.cmd
[17:33:31][Step 1/1] in directory: C:\TeamCity\buildAgent\work\f93452fdf52dbc98
[17:34:06][Step 1/1] Process exited with code 1
[17:34:06][Step 1/1] YSlow
[17:34:06][YSlow] overall score
[17:34:06][overall score] Test ignored: overall score
[17:34:06][Step 1/1] C:\TeamCity\buildAgent\work\f93452fdf52dbc98\homepage.yslow-38.xml report processed: 1 suite, 1 test
[17:34:07]Ant JUnit report watcher
[17:34:07][Ant JUnit report watcher] 1 report found for paths:
[17:34:07][Ant JUnit report watcher] C:\TeamCity\buildAgent\work\f93452fdf52dbc98\homepage.yslow-38.xml
[17:34:07][Ant JUnit report watcher] Successfully parsed
[17:34:07][Successfully parsed] 1 report
[17:34:07][Successfully parsed] homepage.yslow-38.xml
[17:34:07]Publishing internal artifacts
[17:34:07][Publishing internal artifacts] Sending build.finish.properties.gz file
[17:34:07]Publishing artifacts
[17:34:07][Publishing artifacts] Collecting files to publish: [homepage.yslow-38.xml => yslow/homepage]
[17:34:07][Publishing artifacts] Sending homepage.yslow-38.xml
[17:34:07]Build finished

And these are the contents of the report:

<testsuites>
<testsuite name="YSlow" tests="1" failures="1">
<testcase name="overall score" status="D (64)">
<failure/>

</testcase>

</testsuite>

</testsuites>

Thanks
1 comment
Comment actions Permalink

Please, anyone? any help?

0

Please sign in to leave a comment.