teamcity msbuild error MSB1008: Only one project can be specified

Answered

11:09:56]:
Nothing more to be cleaned. Build will be started as is.

[11:09:57]: sln2008 output: "C:\Program Files\TeamCity\buildAgent\bin\..\plugins\dotnetPlugin\bin\JetBrains.BuildServer.MsBuildBootstrap.exe" @xml "C:\Program Files\TeamCity\buildAgent\temp\agentTmp\msbuild7731.teamcity.bootstrap.properties"

TeamCity MSBuild bootstrap v5.0 Copyright (C) JetBrains s.r.o. Start MSBuild... 'c:\WINDOWS\Microsoft.NET\Framework\v3.5\MSBuild.exe' '@"C:\Program Files\TeamCity\buildAgent\work\9691bb0a8c0d21fb\Landmark.CRC.sln.teamcity.msbuild.tcargs" "C:\Program Files\TeamCity\buildAgent\work\9691bb0a8c0d21fb\Landmark.CRC.sln.teamcity.patch.tcprojx"' working dir = 'C:\Program Files\TeamCity\buildAgent\work\9691bb0a8c0d21fb'

Microsoft (R) Build Engine Version 3.5.30729.1 [Microsoft .NET Framework, Version 2.0.50727.3603] Copyright (C) Microsoft Corporation 2007. All rights reserved.

MSBUILD : error MSB1008: Only one project can be specified.

Switch: 4.01 For switch syntax, type "MSBuild /help"
[11:09:57]: Process exit code: 1
[11:09:57]: Build finished




I'm getting above error, not able to find what is the problem? Please help

0
7 comments

Does anybody have any idea? Please help. tried to uninstall and re-install .NET 3.5, teamcity it is still not working.

my project-config.xml looks like this, does anybody spot any problem... in my settings.

<?


xml version="1.0" encoding="UTF-8"?>

<!


DOCTYPE project SYSTEM "../project-config.dtd">

<


project id="project3">

<


build-type id="bt4" name="uma test">

<


description />

<


settings>

<


runner type="sln2008">

<


run-parameters>

<


param name="nunit_version" value="NUnit-2.2.10" />

<


param name="dotNetCoverage.NCover.HTMLReport.File.Type" value="1" />

<


param name="dotNetCoverage.PartCover.Reg" value="selected" />

<


param name="Configuration" value="Debug" />

<


param name="dotNetCoverage.NCover3.runtime" value="x86" />

<


param name="build-file-path" value="umatest.sln" />

<


param name="dotNetCoverage.NCover.Reg" value="selected" />

<


param name="dotNetCoverage.NCover.HTMLReport.File.Sort" value="0" />

<


param name="dotNetCoverage.NCover3.Reg" value="selected" />

<


param name="targets" value="Rebuild" />

</


run-parameters>

</


runner>

<


vcs-settings checkout-mode="ON_SERVER" labeling-type="NONE" labeling-pattern="build-%system.build.number%">

<


vcs-entry-ref root-id="2" set-label="false" />

</


vcs-settings>

<


requirements />

<


build-parameters />

<


build-triggers />

</


settings>

</


build-type>

</


project>
0

Have you found a solution?

0

check your command line args.  if you have a space, it will cause this failure.

0

Please check there are no custom parameters set for MSBuild/Solution runner.

0

The change in command line parameters solves the issue... see here: http://devnet.jetbrains.com/message/5506672#5506672

Best regards,
Veljko

0

I'm implementing a build for a website and I'm getting the same error:

[MSBuild output] Start MSBuild...
[10:25:03][MSBuild output] 'C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\MSBuild\Current\bin\MSBuild.exe' '"@C:\Development\abc\trunk\Website\abc.Website.csproj.teamcity.msbuild.tcargs" C:\Development\abc\trunk\Website\abc.Website.csproj.teamcity'
[10:25:03][MSBuild output] working dir = 'C:\Development\abc'
[10:25:03][MSBuild output] MSBUILD : error MSB1008: Only one project can be specified.
[10:25:03][MSBuild output] Switch: C:\Development\abc\Website\abc.Website.csproj.teamcity
[10:25:03][MSBuild output]
[10:25:03][MSBuild output] For switch syntax, type "MSBuild -help"

The parameters don't contain spaces and seem to be TeamCity generated, so I'm not sure how I can fix this

Thanks

Richard

0

Hi Richard,

 

to debug this we would need to see your exact setup for the build step and which version of TeamCity you are using. As mentioned above, the most common cause is custom command line parameters, but some other parameters might be disrupting the setup.

0

Please sign in to leave a comment.