Teamcity cannot pull the latest a few changesets from git

Hey,

I have an issue regarding pulling new changes from git and hope somebody could help.

The git repository is a daemon - git://host/repo-path. I'm using Teamcity 7.0.4 with two agents. In the configuration page, "Test Connection" shows it's working. However, in the "My Changes" tag, it always misses the latest several changesets. When I create new build, it also misses the latest several changesets.

The TC server crashed a few days ago. Since we used HSQLDB, which is very temporary, the data got lost. I managed to recover the database. The missed changesets are the ones that were commited after the recovery.

A few other observations:

1. If I run "git log" in "~/.BuildServer/system/caches/git/git-B713C2EF.git", it contains the latest changesets, which is good.
2. "~/.BuildServer/system/caches/sources/versions.map" contains an old hash, i.e., the one before the database crash.
3. The symtpom keeps the same after I remove "~/.BuildServer/system/caches" and reboot the server.
4. The symptom keeps the same after I run "Clean sources on this agent" on both agents.
5. The working copy of the source code on both agents are indeed old versions.

I feel the old hash is cached somewhere in the system and TC doesn't update it.

Any help will be appreciated!

[UPDATE] From teamcity-vcs.log, there were entries like:

jetbrains.buildServer.VCS - Finish collecting changes for git://host/repo-path....

But there was no such entry after I repaired the server. It seems like the server didn't pull anything, although the "Change checking interval" is set to be 60 seconds.

1 comment
Comment actions Permalink

Hi,

I have the feeling that I hit the same problem. Did you find a solution back then ?

Olivier

0

Please sign in to leave a comment.