Broken file names with national characters after SVN checkoutby Teamcity.

I have in my SVN repository a file with national characters (Russian language) in it's name. At a machine with a Teamcity agent to be launched, everything is OK if I do manual SVN checkout from operating system's command line, the file's name is correct. After a checkout to be done with Teamcity possibilities I have the file name to be displayed by operating system as a set of question signs - as '????.pdf'.

I have TeamCity Professional 8.0.1 (build 27435) in pair with Debian Wheezy 7.3.

I tried some playing with localization and encodings settings and variables - no luck. The values en_US.UTF-8, ru_RU.UTF8, UTF8, RU, ru have been applied in several combinations in proper places. I'm hoping that the values and places were proper.

Now these variables and values are (I'm not shure all of them are significant for the issue):

Configuration settings for agent:

    teamcity.agent.jvm.file.encoding     UTF8


    teamcity.agent.jvm.user.country      RU
    teamcity.agent.jvm.user.language     ru


Configuration settings for build configuration:

    user.country      RU
    user.language     ru


Environment variables for build configuration:
    env.LANG         en_US.UTF-8
    env.LANGUAGE     en_US:en
    env.LC_ALL



What should I check, in order to locate and fix the issue cause? May I or must I provide some more data about my system? I'm experienced Linux user, but newbie with Teamcity.

Is the issue something well known?


Thank you! I appreciate your help.

2 comments
Comment actions Permalink

Related issue may be reproduced via OS command line, using SVNKit, which is Teamcity's SVN client:

$ LANG="C" LC_ALL="C" jsvn co --force https://.../svn/...
A    Documentation/??????????? ?? ????????? ? ?????????.pdf

0
Comment actions Permalink

The issue was solved.

In

    /etc/rc.local

Instead of

    /opt/BuildAgent/bin/agent.sh start

Was placed

    LANG=en_US.UTF-8  /opt/BuildAgent/bin/agent.sh start

National symbols (Russian language) in the file name after SVN checkout by Teamcity (SVNKit?) are OK now.

0

Please sign in to leave a comment.