TeamCity agent can't connect to server:401 Authorization Required

I have TeamCity server and agent installed on one Windows 2008 server, and now I am installing another agent in my workstation XP. I can start the agent services in my XP, but it's not showing in the server's Agent tab. Here is the agent error I found in XP. How can I let the agent use a user/password?

[2014-02-13 16:40:44,500]   INFO - buildServer.AGENT.registration - Registering on server http://cmtoldshrdjk01.dev.bmocm.com, AgentDetails{Name='OCDT70302123', AgentId=null, BuildId=null, AgentOwnAddress='null', AlternativeAddresses=[10.115.110.172], Port=9091, Version='27767', PluginsVersion='27767-md5-04cc3ba1c597769dca99b821c2d4015a', AvailableRunners=[Ant, dotnet-tools-dupfinder, dotnet-tools-inspectcode, Duplicator, FxCop, gradle-runner, Inspection, Ipr, jb.nuget.installer, jb.nuget.pack, jb.nuget.publish, jetbrains.dotNetGenericRunner, jetbrains.mspec, jetbrains_powershell, JPS, Maven2, MSBuild, MSTest, NAnt, NUnit, rake-runner, simpleRunner, sln2003, VS.Solution], AvailableVcs=[perforce, mercurial, jetbrains.git, svn, cvs, clearcase], AuthorizationToken='fd2ba7561c305fa5f448528d0b5929fe'}
[2014-02-13 16:40:44,562]   WARN - buildServer.AGENT.registration - Call http://cmtoldshrdjk01.dev.bmocm.com/RPC2 buildServer.registerAgent3: org.apache.xmlrpc.XmlRpcClientException: Server returned incorrect status code: 401 Authorization Required
[2014-02-13 16:40:44,562]   WARN - buildServer.AGENT.registration - Connection to TeamCity server is probably lost. Will be trying to restore it. Take a look at logs/teamcity-agent.log for details (unless you're using custom logging).

2 comments
Comment actions Permalink

What version of TeamCity do you use? Do you have proxy server between agent and TeamCity server?

0
Comment actions Permalink

The latest 8.0.6 downloaded from the website, installed on Windows 2008. It's within the same LAN so I don't think there is any proxy server. But how can I put a proxy server setting in TeamCity agent? I can try.

Jirong

0

Please sign in to leave a comment.