Error collecting changes for VCS repository after SVN Dump/Load

I did an SVN dump and load to remove a few bad revisions from my svn history but now TeamCity fails every build config with:
Error collecting changes for VCS repository 'my-project'
Unable to get SVN log entries for:  https://localhost/svn/myproject/branches/JIRA-1488; range:  RR[7745_2013/08/30 18:09:48 -0400 => 7744_2013/09/03 11:06:47  -0400]@cbc05ded-47c6-4a2a-80c9-da6d299001d1; revisions: 7745..7744


This looks similar to the issue mentioned here:
http://devnet.jetbrains.com/thread/284636

However, I'm not confident about generating the correct SQL based on what I can see there.
Also, I am using the internal storage engine, if I need to run SQL to fix this, how do I run it?

3 comments
Comment actions Permalink

I have been able to work around it by creating new VCS roots and detatching all my existing roots then attaching the new roots.
This was a bit tedious so I'd still like to know if there was a better way.

0
Comment actions Permalink

Hello,

in you case, you could have tried to clean out files corresponding to the last version in the <TeamCity data directory>/system/pluginData/repositoryStates/ or you could have clean out them all so the TeamCity could start to create these repository states from scratch.

regrads

Zdenek

0
Comment actions Permalink

I did it again :)

For future reference the content of these files is just xml like

<singleVersion>
  <version>8810_2014/01/23 11:20:52 -0500</version>
  <myTimestamp>2014-01-23 16:20:52.92 UTC</myTimestamp>
</singleVersion>


The default install on Windows was C:\ProgramData\JetBrains\TeamCity\system\pluginData\repositoryStates\
I shut down the server and agents, deleted all the sub-dirs in this directory and started the agents.

However, TeamCity still picked up non-existent revisions from somewhere.

So this time I deleted the contents of C:\ProgramData\JetBrains\TeamCity\system\changes and tried again.
No luck.
I'm going to recreate the roots again :(

0

Please sign in to leave a comment.