Integration with GitHub. unable to download last version


Another bad experience with teamcity. Now I'm trying to get the sources from GitHub. Fortunately, the problem with out of memory was solved via internal property, but now I have another. After setting up fetch url, I always get an error:
Failed to build patch for build # {build id=34}, VCS root: {instance id=10, parent id=1}, due to error: Cannot find commit XXXXXXXXXXXXXXXXXXXXXXX in repository  (C:\projects\ProjectFolder, jetbrains.buildServer.agent.impl.patch.PatchDownloaderImpl$1: Server was not able to build correct patch, most likely due to VCS errors

I tried to clone repository manually, tried to clean all and configure clean setting in VCS root, but still didn't have any luck with this. What I'm doing wron? What teamcity is doing wrong? Anybody have success story integrated teamcity with github?


PS. Honestly, I'm badly surprised after digging into teamcity details. Issue with Mono (still not answered), a lot of manipulations with internal properties for out of memory. Guys, you are doing cool tools but unfortunatelly only very simple steps are working fine (get sources from tfs and build solution). Any other task, which is different lead to huge problems. Most of the time it is really difficult to find an answer.



I'm sorry for the inconvenience.
Teamcity is compatible with GitHub, but the problem you've met is not a known issue, so we'll need to troubleshoot it together.

Could you please send us privately to the next info:
- Screenshots of VCS settings and VCS Root pages
- Debug VCS logs: go to Administration > Diagnostics page, and switch Logging preset to debug-vcs, start new build, reproduce the error, and get teamcity-vcs.log file.

Thank you.


Hi Michael,

Sorry for delay, I will return back to this in the middle of Jun, because right now I'm busy with other activities.



I'm experiencing this issue now.

Failed to start build #5 on <machineName>
Failed to build patch for build #y {build id=x}, VCS root: "ProjectName" {instance id=26, parent internal id=1, parent id=ProjectRoot, description: ""}, due to error: Cannot find commit <commit_hash> in repository (C:\...\system\caches\git\git-FB223D0E.git,
Any updates on this?

I didn't send the logs to Jetbrains because of different reasons.

The thing is that I had to rebuild the VM we have used for CI and after complete reinstall, the problem was not reproduced. I don't know why, probably the order you are installing software does matter. At the first time I remember I installed TeamCity first before Git. Second time I did Git installation first. The next thing - we have moved from github to bitbucket. Probably it also made a difference why I wasn't able to reproduce the issues again.

Gleb, I think you can try two things:
1) Try to create repository on bitbucket, probably make a copy of your project (with full set of commits) and configure teamcity to use bitbucket repository. That will help to understand if it is github integration issue or not.
2) Try to collect logs as Michael suggessted.

It will be great if you keep the community (and me personally) informed about this issue.



Please sign in to leave a comment.