HSQL database exceeds size limit

I know that is my fault, the warning was there several month, but today TeamCity collapsed with unexpected error. The internal database exceeds 2GB and refuse any inserts.
So I followed the instraction for migration to external database (they are excellent by the way) but as migrateDB.cmd is logging its work to the old database so the full migration failed. Also simple db backup failed. I had to migrate from an older backup. Could it be possible to add --no-log option to the maintainDB batch, or don't fail whole process on failed logging?


1 comment
Comment actions Permalink

That's a good point, thank you.

However, your case is quite rare and priority of this work would be low (based on the benefit that average TC users will get from it). Also, since TC 9.0 we will be bunding HSQLDB 2.0, which has greater size limit.

Also, there is a way to extend HSQLDB size to 16GB (http://sourceforge.net/p/hsqldb/discussion/73674/thread/14cf4608).


Please sign in to leave a comment.