Unity3D batchmode build failing with TeamCity

Hi,

I have a Unity3D project I've set up to build with TeamCity 8.1.1, running on JRE 7 with 4GB of heap memory. Recently builds started hanging 100% of the time (log is attached).
According to my search, where it hangs with message (*** HR propagated: -2147024774) relates to insufficient buffer. However, I have no idea how to resolve this issue.
I've tried giving it more memory, upgraded to JRE 8.0, but still the same.

Any help would be greatly appreciated.

Thanks!



Attachment(s):
WIN-V0CD0LEUMR0.LOG.zip
2 comments
Comment actions Permalink

What would happen, if you go to build agent machine, log in as build agent user and run the same build from console?

0
Comment actions Permalink

Thanks for your response. In short, the build is working now. I had set up TeacCity services to run as SYSTEM accounts before, and my guess is that this account somehow was not able to locate my Android SDK installation in despite of having the system variable set up correctly. I now have the services run as the Administrator acccount, and the builds do work fine.

0

Please sign in to leave a comment.