"Access Denied" error while running Selenium Grid test scripts(when it tries to close the browser) from teamcity on a remote machine.

Hi,

I have tried searching it on google but didn't get an answer for this.
So, i thought someone with knowledge of teamcity might be able to help and therefore posting it here.

I've setup a selenium grid project to distribute tests on remote machines.
The programming language used is python and  test runner is py.test

I am able to launch selenium grid tests from teamcity and it starts to run test scripts in parallel.
But, when the script goes to the step where it should close the browser, i get the following error. "[16:26:45][Step 1/1] ERROR killing: [Error 5] Access is denied"

Attached is the extract from log file:

If i run the project from command prompt and run the scripts it works fine and closes the browser and starts up the next script.

The problem is when i launch the project from teamcity, then only i get this error.

I know that the teamcity agent running on remote machine has admin rights and confirmed it with local IT support team.

Can someone please give any ideas about how to solve this problem?

Thanks in advance.

Best Regards,
Manjeet



Attachment(s):
Functional_Tests_Functional_Test_-_PDP_Trunk_-_CT_-_GridProduct_Development_22.log.zip
1 comment
Comment actions Permalink

I would probably start with double-checking that script can be run properly as an agent. Especially, if build agent is installed as a service on windows machine - you need to check its ability to create and close browser properly. I would start with a simple test that only opens a google.com homepage and then closes the browser.

Also, briefly looked into build log, you have the following error repeated a lot of time: framework\unit\castor_unittest.py:19: AttributeError. Probably, it can be the case too.

0

Please sign in to leave a comment.