Problem publishing artifacts

Hi

I have a simple build setup, that copies all artifact files to destination server. My repo has just grown to 2.5 Gb in size. Most of the files are flash and video files for eLearning courses.

Here's a snip from the log. The first part is the robocopy output. The copy seems to go fine, but after that the "Publishing artifacts" seems to run forever, resetting every 4-5 minutes until a timer of approx. an hour, then the build fails, and a new one is started with the same result.


I'm running v8.1.1 on Windows 2008 R2

Is there any way to track down this issue?

[18:57:22]

[18:57:22]               Total    Copied   Skipped  Mismatch    FAILED    Extras

[18:57:22]    Dirs :        69        39        30         0         0         0

[18:57:22]   Files :      1677      1677         0         0         0         0

[18:57:22]   Bytes :   2.570 g   2.570 g         0         0         0         0

[18:57:22]   Times :   0:11:04   0:10:58                       0:00:00   0:00:06

[18:57:22]

[18:57:22]

[18:57:22]   Speed :             4192059 Bytes/sec.

[18:57:22]   Speed :             239.871 MegaBytes/min.

[18:57:22]

[18:57:22]   Ended : Fri May 02 18:57:22 2014

[18:57:22]Process exited with code 0

[18:57:22]Publishing internal artifacts

[18:57:22]Publishing artifacts (running for 47m:16s)

[18:57:22][Publishing artifacts] Collecting files to publish: [sonderborg/**]

[18:57:22][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[18:57:22][Publishing artifacts] Publishing using [WebPublisher]

[19:00:13][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:00:13][Publishing artifacts] Publishing using [WebPublisher]

[19:04:03][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:04:03][Publishing artifacts] Publishing using [WebPublisher]

[19:08:11][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:08:11][Publishing artifacts] Publishing using [WebPublisher]

[19:12:30][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:12:30][Publishing artifacts] Publishing using [WebPublisher]

[19:17:00][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:17:00][Publishing artifacts] Publishing using [WebPublisher]

[19:22:04][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:22:04][Publishing artifacts] Publishing using [WebPublisher]

[19:26:56][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:26:56][Publishing artifacts] Publishing using [WebPublisher]

[19:33:35][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:33:35][Publishing artifacts] Publishing using [WebPublisher]

[19:38:59][Publishing artifacts] Publishing using [ArtifactsCachePublisher]

[19:38:59][Publishing artifacts] Publishing using [WebPublisher]

[19:44:39]Build canceled


3 comments
Comment actions Permalink

Hello Lars,

1. What artifacts are you trying to publish? Is it some kind of report?
2. Please, attach here relevant part of teamcity-agent.log file (you can find it in BuildAgent/logs directory))

0
Comment actions Permalink

Hi, actually I found a log with some information. It seems that the webserver is throwing an error upon submitting the files for archive, and the error is not handled by Teamcity.
Errorcode is 404.13, and seems to refer to the fact that the requestmessagelength is too large.

I wonder how to set this, because the IIS on the server is redirecting to the Teamcity server on another port through a server farm setup.

Thanks for guiding me towards this log.

Maybe you can tell: what is the purpose of archiving? As I see now, the build process first copies all files to destination server (in a build step) and after that it seems to send the files to the teamciy server for archiving. I have set up the process to copy all files (the same files that go to prodserver also goes to archive)...
But with 2.5 Gb of binary files it suddently seems too much. The files are also included in the git version control, so it now gives many copies...

Can archiving be skipped?


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>IIS 7.5 Detailed Error - 404.13 - Not Found</title>
<style type="text/css">
<!--
body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;background:#CBE1EF;}
code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;}
.config_source code{font-size:.8em;color:#000000;}
pre{margin:0;font-size:1.4em;word-wrap:break-word;}
ul,ol{margin:10px 0 10px 40px;}
ul.first,ol.first{margin-top:5px;}
fieldset{padding:0 15px 10px 15px;}
.summary-container fieldset{padding-bottom:5px;margin-top:4px;}
legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;}
legend{color:#333333;padding:4px 15px 4px 10px;margin:4px 0 8px -12px;_margin-top:0px;
border-top:1px solid #EDEDED;border-left:1px solid #EDEDED;border-right:1px solid #969696;
border-bottom:1px solid #969696;background:#E7ECF0;font-weight:bold;font-size:1em;}
a:link,a:visited{color:#007EFF;font-weight:bold;}
a:hover{text-decoration:none;}
h1{font-size:2.4em;margin:0;color:#FFF;}
h2{font-size:1.7em;margin:0;color:#CC0000;}
h3{font-size:1.4em;margin:10px 0 0 0;color:#CC0000;}
h4{font-size:1.2em;margin:10px 0 5px 0;
}#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS",Verdana,sans-serif;
color:#FFF;background-color:#5C87B2;
}#content{margin:0 0 0 2%;position:relative;}
.summary-container,.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
.config_source{background:#fff5c4;}
.content-container p{margin:0 0 10px 0;
}#details-left{width:35%;float:left;margin-right:2%;
}#details-right{width:63%;float:left;overflow:hidden;
}#server_version{width:96%;_height:1px;min-height:1px;margin:0 0 5px 0;padding:11px 2% 8px 2%;color:#FFFFFF;
background-color:#5A7FA5;border-bottom:1px solid #C1CFDD;border-top:1px solid #4A6C8E;font-weight:normal;
font-size:1em;color:#FFF;text-align:right;
}#server_version p{margin:5px 0;}
table{margin:4px 0 4px 0;width:100%;border:none;}
td,th{vertical-align:top;padding:3px 0;text-align:left;font-weight:bold;border:none;}
th{width:30%;text-align:right;padding-right:2%;font-weight:normal;}
thead th{background-color:#ebebeb;width:25%;
}#details-right th{width:20%;}
table tr.alt td,table tr.alt th{background-color:#ebebeb;}
.highlight-code{color:#CC0000;font-weight:bold;font-style:italic;}
.clear{clear:both;}
.preferred{padding:0 5px 2px 5px;font-weight:normal;background:#006633;color:#FFF;font-size:.8em;}
-->
</style>

</head>
<body>
<div id="header"><h1>Server Error in Application "TEAMCITY.GUIDE2WORK.DK"</h1></div>
<div id="server_version"><p>Internet Information Services 7.5</p></div>
<div id="content">
<div >
<fieldset><legend>Error Summary</legend>
  <h2>HTTP Error 404.13 - Not Found</h2>
  <h3>The request filtering module is configured to deny a request that exceeds the request content length.</h3>
</fieldset>
</div>
<div >
<fieldset><legend>Detailed Error Information</legend>
  <div id="details-left">
   <table border="0" cellpadding="0" cellspacing="0">
    <tr ><th>Module</th><td>RequestFilteringModule</td></tr>
    <tr><th>Notification</th><td>BeginRequest</td></tr>
    <tr ><th>Handler</th><td>Not yet determined</td></tr>
    <tr><th>Error Code</th><td>0x00000000</td></tr>
     
   </table>
  </div>
  <div id="details-right">
   <table border="0" cellpadding="0" cellspacing="0">
    <tr ><th>Requested URL</th><td>xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx</td></tr>
    <tr><th>Physical Path</th><td>xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx</td></tr>
    <tr ><th>Logon Method</th><td>Not yet determined</td></tr>
    <tr><th>Logon User</th><td>Not yet determined</td></tr>
     
   </table>
   <div ></div>
  </div>
</fieldset>
</div>
<div >
<fieldset><legend>Most likely causes:</legend>
  <ul>  <li>Request filtering is configured on the Web server to deny the request because the content length exceeds the configured value.</li> </ul>
</fieldset>
</div>
<div >
<fieldset><legend>Things you can try:</legend>
  <ul>  <li>Verify the configuration/system.webServer/security/requestFiltering/requestLimits@maxAllowedContentLength setting in the applicationhost.config or web.config file.</li> </ul>
</fieldset>
</div>


<div >
<fieldset><legend>Links and More Information</legend>
  This is a security feature. Do not change this feature unless the scope of the change is fully understood. You can configure the IIS server to reject requests whose content length is greater than a specified value. If the request's content length is greater than the configured length, this error is returned. If the content length requires an increase, modify the configuration/system.webServer/security/requestFiltering/requestLimits@maxAllowedContentLength setting.
  <p><a href="http://go.microsoft.com/fwlink/?LinkID=62293&amp;IIS70Error=404,13,0x00000000,7601">View more information &raquo;</a></p>
   
</fieldset>
</div>
</div>
</body>
</html>

0
Comment actions Permalink

So problem is solved by going to the IIS7, in request filtering, changing the "Maximum allowed content length" from 30000000 to 300000000.

I think the problem was that one of the artifacts exceeded 30Mb in size.

0

Please sign in to leave a comment.