Build Queue stuck

It has not been my week for having TeamCity work smoothly. As I mentioned in a different thread, I am currently moving our VCS from Visual Source Safe to Team Foundation server. We actually have two TeamCity servers, and other than some minor timing issues with one build configuration on the one server, it is running after the switch.

The second server however is having the issue where Build Configurations that are in the Build Queue are never being sent to the Build Agent. The first build in the queue displays as Delayed, with tooltip text of "The build should start shortly."  When reconfiguring this server, I copied the old Build Configurations and archived the original Build Configurations, then made changes to the new ones. The VCS roots are correctly seeing changes made in TFS and builds are being added to the queue. But they are not leaving the queue. I have also tried adding manual queues to the build, but they too are stuck. Lastly, I unarchived one of the old Build Configurations and added a manual build. That too is not working.

Attached is a screen shot of the build queue. As you can see, there is one Agent available and all of the builds can be run on 1 Agent (i.e. there is a non-busy valid Build Agent). The Pause Queue button comes from a Plugin, but the queue is not currently paused (I have also tried toggling it, also with no success).

Any ideas?

Thanks,
~Alex

P.S. I am using TeamCity version 7.0.4



Attachment(s):
TeamCity Build Queue issue.png
2 comments
Comment actions Permalink

Looks like it is the same problem as in this thread http://devnet.jetbrains.com/message/5516663#5516663. We need temcity-server.log in debug-general mode to investigate it.

0
Comment actions Permalink

I am unable to reproduce this error this morning (which is a good thing, since Build Configurations are actually building now).

Additionally, this is a different TeamCity server than the other thread (which I am still having issues with).

Thanks for the help. I'll continue to monitor if this happens again.

~Alex

0

Please sign in to leave a comment.