Teamcity 8.1.2 SVN authentication

Hi,
Just installed TeamCity 8.1.2 and trying to configure it to work with svn. I'm getting this error: E170001: Authentication required for '<svn://xxx.xxx.xxx.xxx:3690> ' although the credentials are correct.


Type of VCS: Subversion
VCS Root: SvnTrunk
URL: svn://xxx.xxx.xxx.xxx/trunk
Username: A
Password: B
Use default config directory: YES
Configuration directory: c:\Users\[myUser]\AppData\Roaming\Subversion
Externals support:Full support (load changes and checkout).

Any help would be appreciated. Cheers

5 comments
Comment actions Permalink

Hi,

Did you test connection to SVN repository using SVN client (for example Tortoise)? Are you able to checkout repository with the same credentials?

0
Comment actions Permalink

Same problem here.

I've googled a lot, changed the svnkit.http.methods in TEAMCITY_SERVER_OPTS environment variable, and still no luck.

I had the same scenario. The svn server is in the intranet with Windows Authentication. The teamcity server runs as a service (i tried with a domain account and as a local service)

I can access via Tortoise and via web (https://internalserver/svn/blahrepo) without problems but when i press the Test Connection button in TeamCity the error says: (E170001: Authentication required for '<svn://xxx.xxx.xxx.xxx:3690>)

And when i insert my credentials in the box:

SVN Connection Settings
URL: *
Username:
Password:



The error says:

Test connection failed in XrmCommerce :: Web :: Trunk. svn: E170001: Negotiate authentication failed: 'No valid credentials provided'

I think that the error is with SVNKit but i dont know how to fix it.

I used TeamCity a lot in the past with svn under basic authentication, with tfs, etc, but i'm lost right now :(.

Thanks in advance and sorry for my english

0
Comment actions Permalink
We had the same problem. We have used Version 8.0.6 instead, which works fine.
0
Comment actions Permalink

Its good to know that. I'll try with that version but its a shame.

Thanks for the tip!

0
Comment actions Permalink

I created an issue http://youtrack.jetbrains.com/issue/TW-37220. Please watch and vote.

0

Please sign in to leave a comment.