TeamCity no longer building pending changes

We have been using TeamCity for well over a year now. We are currently running version 8.0.1. A couple of nights ago we deleted one of our build configurations and added a new one. Since then the build triggers on ALL the configurations seem to have stopped working. TeamCity is detecting git checkins and shows them on the build configurations as pending changes but builds are not getting queued. I have tried pausing/acitivating the build configurations. I have tried disabling/enabling the build triggers. I even went as far as restarting the TeamCity server. Nothing is working. We do have available agents and I can manually trigger the builds so the system is functional. I have started looking through the TeamCity server logs and have found no errors.

Is there some sort of global flag for enabling/disabling the build queue that could have gotten set?

Has anyone seen a similar issue? Any ideas on where to go next to debug the problem?

Any and all help greatly appreciated.

Michael

2 comments
Comment actions Permalink

Could you please:

  1. enable debug for the server (e.g. use "debug-all" preset in Administration | Diagnostics | Troubleshooting));
  2. commit a change and wait for the build not starting for several times more then quiet period that you have for the VCS root;
  3. attach teamcity-server.log and teamcity-vcs.log files;
  4. please also attach settings of the VCS trigger that should trigger the build and General Settings of the build configuration.
0
Comment actions Permalink

Sorry for not responding to your follow up. We were in the middle of getting a release out the door. Two days after posting this the problem stopped happening. Builds are getting properly triggered though we are still seeing github pull requests listed as "pending" that have been merged and closed. At this point we are planning to upgrade TeamCity and see if that helps with the problem.

Thanks,
Michael

0

Please sign in to leave a comment.