default label format in "Label this Build Source"

After upgrading to 8.1.4 yesterday I have found a change in behaviour which I need help on please.

Before the upgrade I had Labelling information set to the format I want but I de-selected the Label all Builds check box so there was NO automatic build labelling.

Then we used the "Label this Build" link on a build which we specifically want to label (e.g. because it was actuallyreleased) so that we can selectivly label some builds and not others. The bahviour of this link was to display a pop-up in the UI which automatically brought up the default Labelling text in the text box. In this way we could get a standard label format (e.g. "Core %env.AsmVersionEMX%").

Since uopdating to 8.1.4 I see the source labelling has been moved to a build feature and I can see how to use it and I have disabled it because i do not want builds to be labelled successfully. However, the pop-up in the UI no longer displays the default text which means it has to be entered manually which is going to lead to errors.

How can I get the ui to display the label text for me as it did before?

3 comments
Comment actions Permalink

Have you tried setting the VCS Labeling build feature but with a branch filter excluding all branches?

Give this a go:
VCS root to label: <Your Root>
Labeling pattern: Core %env.AsmVersionEMX%
Branch filter:-:*
Tick label successful builds only.

This *might* get you what you are after.

0
Comment actions Permalink

Hi,

Yes, the behavior have been changed and unfortunately we have no workaround.
I've created a feature request, please watch/vote for it.

0
Comment actions Permalink

(We also relied on this feature to let all devs explicitly label the releases with proper formatting, noticed after upgrade it was now empty. What a pity...)

0

Please sign in to leave a comment.