Teamcity exception and data directory reseted ?

Hello,

TeamCity 8.1.4 behaved in an unexpected way yesterday. I did my install, put up a project and everything was okay until I got an exception restarting the server (lost stacktrace sorry). For some reason TC reseted itself and didn't want my old data directory anymore (under /home). For some reason it created one under /root, which I do not want.
I tried to force the location of the directory through env variable but it doesn't work (and yes I restarted my machine). So what gives ?

Thanks

3 comments
Comment actions Permalink

Hi,

Please check that environment variable is correct in the same console where you start TC scrip and under the same user. Could you please attach console output and teamcity-server.log file?

0
Comment actions Permalink

Actually I think it created the data dir under /root/ since I ran runAll.sh with sudo because otherwise I get this:

It seems the directory (/opt/TeamCity/webapps/ROOT/WEB-INF/plugins/.unpacked) is not writeable. TeamCity requires it to be writeable.
/opt/TeamCity/webapps/ROOT/WEB-INF/plugins/.unpacked/testfile.txt (Permission denied)


And indeed .unpacked is root's... So I just did a chown and I fixed it. Thanks anyway.

0
Comment actions Permalink

Permission issue

0

Please sign in to leave a comment.