Help. Can't set configuration/working folder for CMake project.

Hello! I have some problem with TeamCity configuration for CMake. I build project for MinGW, but can't set up "working directory" from TeamCity will call cmake util.I read http://confluence.jetbrains.com/display/TCD65/Build+Working+Directory and trying set up like thishttps://dl.dropboxusercontent.com/s/k5anb9855hcp8fk/ACS%202014-10-06%2013-22-25.png
but nothing... Also I trying write direct to buildAgent.properties like "system.teamcity.build.workingDir = MyBuildDir" and it's appeared in System Properties of Agent in Build Parameters and again nothing... TeamCity still build configuration files in checkout directory.

https://dl.dropboxusercontent.com/s/9eif6sah3h42vuf/ACS%202014-10-06%2013-46-09.png
Also I trying this way http://forum.vingrad.ru/forum/topic-344069.html - no succeed :(

I want run CMake from another folder, like:
cd Build
cmake -DCMAKE_TOOLCHAIN_FILE=Toolchain-mingw32.cmake ..


Build log was attached. Thanks.


Attachment(s):
Build_88.log.zip
3 comments
Comment actions Permalink

Hi,

"Working directory" is not CMake parameter, it's TeamCity's one. To specify it please press "Show advanced options" at the bottom of build step settings and Working Directory field will appear. Please enter needed build location there.

0
Comment actions Permalink

Oh my gosh!  I thought that "Additional parameters" it's TeamCity's dependencies. Thank you! I would never have noticed this little button "Show advanced options". I don't understand why JetBrains hidden it, but you should added it to article - https://confluence.jetbrains.com/display/TCD8/Build+Working+Directory :)

Regards.

0
Comment actions Permalink

You are welcome!
Thank you for the feedback. We'll upgrade our documentation.

0

Please sign in to leave a comment.