Bug when connecting to Sql Server in setup of 8.1.5

Hi,

When setting up the TeamCity 8.1.5, during the initialization phase, I'm prompted to enter connection properties to various DB servers.

I've chosen Sql Server (as we're using the SqlServer 2012), and copied the newest sqljdbc41.jar file to TeamCity data folder (hit the button to refresh the driver), and entered the properties for connection to the server including port and database instance name and credentials (user name and password).

Even though I entered the port 1433 (the default for installing SqlServer), the TeamCity can't connect saying the port 1434 should be enabled - as if my port setting isn't being used to connect.
I've tried different (older) versions of MS jdbc drivers, but with the same result. Note that I'm able to connect via Sql Server Management Studio, and that the Browser is up and running.


I've then went to SqlServer configuration, and reconfigured the server by changing the sql server ports to 1434 and now it works, but I believe that this should be fixed.


(If anyone's interested, here's how you change configuration of SqlServer

Go to:
1. Sql Server Configuration Manager \ Sql Native Client 11.0 Configuration \ Client Protocols \  TcpIp \ Default Port \ change 1433 to 1434
2. Sql Server Configuration Manager \ Protocols for <your instance name> \ TCP/IP \ IP Addresses \ IPAll \ TCP Port (was empty)  set to 1434
3. Restart Sql Server (run the services.msc, find the Sql Server - rightclick and choose restart; or from within your mssql management studio right click the root node in object explorer and choose restart...)
)


Thanks,
Veljko

3 comments
Comment actions Permalink

Hi Veljko,

Where did you enter 1433 port? Could you please attach teamcity-server.log file and used database.properties file?
If it is possible please attach the full error message (screenshot) and a screenshot of DB settings.

Message was edited by: Alina Mishina

0
Comment actions Permalink

Hi Alina,

I've reinstalled it now on my local pc, trying to replicate the message, but I cannot.

Now, I'm thinking that I must've had a typo in the name of the host, or probably missed the ":" between the host and the port number... not sure... anyway, it looks like it was my bad... sorry for the false alarm!

Thanks!

0
Comment actions Permalink

No problem. Glab it works now!

0

Please sign in to leave a comment.