TeamCity 9 - NuGet Server not showing packages

Hello,

So I have already searched for similar topics and tried some of the suggestd resolutions to no avail.  I had originally installed TeamCity 8 and setup the NuGet Server as per the blog posting I saw showing how to publish the NuGet package as an artifact.  All worked as expected.  As this was an initial project and test I decided to upgrade to version 9 before I completed the build setup.  Upgrading the server with the same build confguration resulted in the NuGet packages not being shown in Visual Studio as they had while using Version 8.  I tried multiple configuration changes, even deleting the project and starting from scratch.  After much head banging and frustration I decided to completely kill my v9 installation and DB and start with a fresh version 9 install.  I still cannot get the packages to show in the VS package manager regardless if I select Pre-Release or Stable Only.  Calling the URL with /Packages() results in some XML with the package information but I still cannot get anything to show in VS.  

What has changed between 8 and 9?  Am I missing some configuration?  If I look at the XML from the /Packages() call I see a URL to download the package.  I can download and store in a local directory which VS can read and detect the package.  This seems to indicate something is working but my direct feed to the NuGet server is not.  I will attach the output of the /Packages() call in case there is something obvious to those in the know that I am doing wrong.

Any help would be greatly appreciated.

PS: I replaced the URL before posting the attachment.  The URL is an exernally accessible URL and if I put the download URL into a browser from the VS machine it does download correctly



Attachment(s):
Packages.txt.zip
2 comments
Comment actions Permalink

Hi Charles,

It seems to be the same issue as https://youtrack.jetbrains.com/issue/TW-39347. Please watch/vote for it.

0
Comment actions Permalink

Setting teamcity.nuget.api.version=v1 in internal.properties seemed to resolve this issue.

0

Please sign in to leave a comment.