Team City Connection to VSO fails

Hi
I am having a problem with linking TC to VSO and here are the things i have tried on 8.1.1 and now 9.0.1:

I have tried numerous times with the windows live ID having set the alternate credentials and using the Account Service.

i created a new VCS root for the connection but it seems even if i have invalid details in there URL, Username or Root, when i test connection it says its successful no matter what. Anyway i am ensuring that the details are correct and then as soon as i link the VCS root to a Build configuration I am getting the following error from the build log and below that the entery in the teamcity-tfs.log.

Failed to collect changes, error: Failed to get current version of TFS root. TF400324: Team Foundation services are not available from server [VSOName].visualstudio.com\DefaultCollection. Technical information (for administrator):   Unable to connect to the remote server

[2015-01-07 16:37:54,491]   WARN - TfsPooledProcess.pooledProcess - TF400324: Team Foundation services are not available from server [VSOName].visualstudio.com\DefaultCollection.
[2015-01-07 16:37:54,492]   WARN - TfsPooledProcess.pooledProcess - Technical information (for administrator):
[2015-01-07 16:37:54,492]   WARN - TfsPooledProcess.pooledProcess - Unable to connect to the remote server
[2015-01-07 16:37:54,498]   INFO - vcs.tfs.SimpleTfsProcessRunner - TFS command failed. ExitCode: 111, command: C:\TeamCity\webapps\ROOT\WEB-INF\plugins\tfs\bin\tfs-native.exe @@C:\TeamCity\temp\TC-TFS-85-8611_662\command.params, in file: {https://[VSOName].visualstudio.com/DefaultCollection, /user:***** Service ([VSOName]), /password:***** /hash:S, C:\TeamCity\temp\TC-TFS-85-8611_661.result, GetCurrentVersion}, completed in: 63 second(s)
stdout: TFS Native Verifier v9.0 Copyright (C) 2006-2013 JetBrains s.r.o.
Running under .NET Framework 4.0.30319.18408
INFO  -
INFO  - Use Team Explorer 2013
INFO  -
TFS Native Accessor v9.0 Copyright (C) 2006-2013 JetBrains s.r.o.
INFO  - Connecting to server https://[VSOName].visualstudio.com/DefaultCollection
Get current version:
  Server='https://[VSOName].visualstudio.com/DefaultCollection'
  Username='Account Service ([VSOName])'
ERROR - TF400324: Team Foundation services are not available from server [VSOName].visualstudio.com\DefaultCollection.
Technical information (for administrator):
  Unable to connect to the remote server
INFO  - Microsoft.TeamFoundation.TeamFoundationServiceUnavailableException: TF400324: Team Foundation services are not available from server [VSOName].visualstudio.com\DefaultCollection.
Technical information (for administrator):
  Unable to connect to the remote server ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond [IP Address]:443
   at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
   --- End of inner exception stack trace ---
   at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at Microsoft.TeamFoundation.Client.Channels.TfsHttpWebRequest.SendRequestAndGetResponse(HttpWebRequest webRequest, WebException& webException)
   --- End of inner exception stack trace ---
   at Microsoft.TeamFoundation.Client.Channels.TfsHttpWebRequest.ReadResponse(HttpWebResponse webResponse, WebException webException)
   at Microsoft.TeamFoundation.Client.Channels.TfsHttpWebRequest.IsAuthenticationChallenge(TfsMessage requestMessage, HttpWebResponse webResponse, WebException webException, TfsMessage& responseMessage)
   at Microsoft.TeamFoundation.Client.Channels.TfsHttpWebRequest.SendRequest()
   at Microsoft.TeamFoundation.Client.Channels.TfsHttpRequestChannel.Request(TfsMessage message, TimeSpan timeout)
   at Microsoft.TeamFoundation.Client.Channels.TfsHttpClientBase.Invoke(TfsClientOperation operation, Object[] parameters, TimeSpan timeout, Object[]& outputs)
   at Microsoft.TeamFoundation.Framework.Client.Registration.GetRegistrationEntries(String toolId)
   at Microsoft.TeamFoundation.Framework.Client.RegistrationProxy.GetRegistrationEntries(String toolId)
   at Microsoft.TeamFoundation.Framework.Client.RegistrationService.RefreshMemoryCache()
   at Microsoft.TeamFoundation.Framework.Client.RegistrationService.RefreshCachesIfNeeded(Boolean direct)
   at Microsoft.TeamFoundation.Framework.Client.RegistrationService.GetRegistrationEntries(String toolId)
   at Microsoft.TeamFoundation.Framework.Client.PreFrameworkServerDataProvider.FindServiceLocation(String serviceType, String toolId)
   at Microsoft.TeamFoundation.Framework.Client.PreFrameworkServerDataProvider.LocationForCurrentConnection(String serviceType, Guid serviceIdentifier)
   at Microsoft.TeamFoundation.Client.TfsConnection.EnsureProviderConnected()
   at Microsoft.TeamFoundation.Client.TfsConnection.Disconnect()
   at JetBrains.TeamCity.Tfs.TfsLogin.TFSDispose(TfsTeamProjectCollection t) in c:\BuildAgent\work\e63a9343a8da23cf\TfsNativeAccessor\src\TfsLogin_VS12.cs:line 17
   at JetBrains.TeamCity.Tfs.TfsLoginBase`1.DoWithAuthenticatedConnection(String server, String username, String password, JBAction`1 action) in c:\BuildAgent\work\e63a9343a8da23cf\TfsNativeAccessor\src\TfsLogin.cs:line 48
   at JetBrains.TeamCity.Tfs.Command.Do() in c:\BuildAgent\work\e63a9343a8da23cf\TfsNativeAccessor\src\Command.cs:line 27
   at JetBrains.TeamCity.Tfs.Program.Main(String[] args) in c:\BuildAgent\work\e63a9343a8da23cf\TfsNativeAccessor\src\Program.cs:line 438
stderr: TF400324: Team Foundation services are not available from server [VSOName].visualstudio.com\DefaultCollection.
Technical information (for administrator):
  Unable to connect to the remote server
[2015-01-07 16:37:54,503]  ERROR - ers.vcs.tfs.TfsNativeExeRunner - tfs error MAT OCS VSO ATLAS {internal id=92}: TF400324: Team Foundation services are not available from server [VSOName].visualstudio.com\DefaultCollection.
Technical information (for administrator):
  Unable to connect to the remote server

I then find a number of posts about being behind a corporate proxy and how i should add proxy details to the internal.properties so i have added the following:

-Dhttp.proxyHost=proxy.domain.com
-Dhttp.proxyPort=8080
-Dhttps.proxyHost=proxy.domain.com
-Dhttps.proxyPort=8080
-Dproxyset=true
teamcity.tfs.useSystemProxy=true

Yet i still get the error above. Its got to be something internal I think but its very strange (and irritating) that the Test Connection works even with wrong details and then fails when connected to a configuration. Anyone got any more suggestions?
1 comment
Comment actions Permalink

Note to self.... restart TeamCity after adding config to internal.properties DOH!

0

Please sign in to leave a comment.