A current state of vcs root is outdated, skip a changes collecting

The server running TeamCity somehow manage to get its time ahead by a month. Once I resynced the time, I got log entries similar to the following appearing in teamcity-vcs.log: "A current state of vcs root "my VCS root" is outdated, skip a changes collecting". Now my VCS Trigger isn't working and manually triggering the "check for pending changes" action is failing to find changes.

Manully running a build on a project which has a never revision in source contral, causes the last revision built by TeamCity to be built again, rather than the latest revision in source control. This build gets sorted by started date (so doesn't appear at the top) and has the following message next to a warning icon during the build: "This build is outdated (more recent build is already finished). Click the icon to check the newer results".

I've tried reseting the following caches:
- Build history
- buildsMetadata
- sources
- vcsContentCache (didn't show empty after a while like the others)

When changing "active logging preset" to debug-vcs I get the following log entry: Calculate final revision for VcsRootEntry[VcsSettings..., upper limit revision RepositoryVersion{myVersion='11198_2015/02/03 14:18:35 +0000', myDisplayVersion='11198', myVcsBranch='null'}
The latest revision for the project that it is building is 11199, which was committed today (7 January 2015), but revision 11198 was committed yesterday when it thought that the date was 3 February 2015. The source control is on a separate server, where the time is correct now and was correct yesterday as well.

How can I get TeamCity to notice the VCS changes without setting the time back to an incorrect value?

I'm using TeamCity 9.0 (build 32060)

1 comment

Please sign in to leave a comment.