Not able to run any commands on build agent installed on HPUX

hi..
I am trying to setup a build agent on HPUX server. I am able to start the build agent service on HPUX and Teamcity server is able register the build agent from the portal.
When I try to run any command (simple "ls -al") as part of the build process on the same build agent it is giving following error:

Process exited with code 255

Complete TC build log is:

[10:17:49]Checking for changes

[10:17:49]Publishing internal artifacts

[10:17:49][Publishing internal artifacts] Sending build.start.properties.gz file

[10:17:49]Clearing temporary directory: /home/xxx/tc-agent-bin/temp/buildTmp

[10:17:49]Checkout directory: /home/xxx/tc-agent-bin/work/6310ad967797a74d

[10:17:49]Updating sources: agent side checkout (1s)

[10:17:50][Updating sources] VCS Root: svn: http://xxx/svn/TEST_UNIX_SC_DF_MOD_011015 (1s)

[10:17:50][VCS Root: svn: http://xxx/svn/TEST_UNIX_SC_DF_MOD_011015] checkout rules: trunk=>; revision: 3_2015/01/11 08:31:36 -0800

[10:17:50][VCS Root: svn: http://xxx/svn/TEST_UNIX_SC_DF_MOD_011015] Set working copy format to 1.7

[10:17:50][VCS Root: svn: http://xxx/svn/TEST_UNIX_SC_DF_MOD_011015] Fast SVN update is enabled

[10:17:51]Starting: /home/xxx/tc-agent-bin/temp/agentTmp/custom_script1414256226968124873

[10:17:51]in directory: /home/xxx/tc-agent-bin/work/6310ad967797a74d/build

[10:17:51]Process exited with code 255

[10:17:51]Publishing internal artifacts

[10:17:51][Publishing internal artifacts] Sending build.finish.properties.gz file

[10:17:52]Build finished



it is able to extract the code from SVN server.

Please let me know, if you need any additinal information.

Build agent is running port 9090.

I am able to connect to build agent port 9090 from the teamcity server so there is no firewall issue.



Thanks ..
Rajan.
5 comments
Comment actions Permalink

any help please ?

0
Comment actions Permalink

Hi Rajan,

Please check that the same commands run fine on TeamCity agent machine under the same user that the agent is running, with the same environment variables and the same working directory. For more details please see the related doc section.

0
Comment actions Permalink

Hi Alina,
I tried simple shell script. I am able to run it on the agent machine with the same user and environment variable.
I even tried running just '/usr/bin/ls -al' command and even that returns error 'Process exited with code 255'.

Please let me know, if you want me to enable any debug flags to get additional information in the log files for server and agent.

Thanks ..
Raviraj.

0
Comment actions Permalink

Hi Rajan,

Sorry for delay. Please try to run command line build step with option "executable with parameters" and specify Command executable: ls, Command parameters: -la. Does it work?

0
Comment actions Permalink

Dear Alina,

4 years later I can confirm that it works :D

This issue gave me a headache. The question is why does it work this way? :P

0

Please sign in to leave a comment.