LDAP Synchronization does not create new users

Hi

I've configured LDAP for TeamCity. First sync trail fail. According to the teamcity-ldap.log all users were found but no created:
[2015-01-30 08:04:53,077]   INFO -     jetbrains.buildServer.LDAP - User ... (remote ID: 'CN=...,OU=Users,OU=...,DC=...,DC=...') should be created, but automatic user creation is disabled.

I set teamcity.options.createUsers to true but no users were created.

[2015-01-30 08:13:26,375]   INFO -     jetbrains.buildServer.LDAP - Found 224 search results for search base='OU=Users,OU=....', filter='(objectClass=User)', scope=2, attributes=[mail, sAMAccountName, displayName]
[2015-01-30 08:13:26,375]   INFO -     jetbrains.buildServer.LDAP - Last synchronization statistics: created users=0, updated users=0, deleted users=0, remote users=224, matched users=2, created groups=0, updated groups=0, deleted groups=0, remote groups=0, matched groups=0, duration=250ms, errors=[]

What do I have to change that the users are created?

Thanks



Attachment(s):
teamcity-ldap.log.zip
ldap-config.properties.zip
5 comments
Comment actions Permalink

Hi Daniel,

Please attach your ldap-config.properties and full teamcity-ldap.log file.

0
Comment actions Permalink

I've attached the log and config file.

Thanks

0
Comment actions Permalink

Please add one more option: teamcity.options.users.synchronize.createUsers=true.
For more details please see the related issue https://youtrack.jetbrains.com/issue/TW-33197.

0
Comment actions Permalink

Thanks, that was the problem!

0
Comment actions Permalink

Hi Daniel,

Note: it is not recommended to use teamcity.options.users.synchronize.createUsers=true option, because it can be removed in the future versions of TeamCity.
As for now TeamCity can automatically create users in TeamCity, if they are found in one of the mapped LDAP groups and groups synchronization is turned on via teamcity.options.groups.synchronize option. So please confgure group synchronization.

Sorry for the inconvenience.

0

Please sign in to leave a comment.