NuGet restore works on some build agents

We're running into the issue where certain builds only work on certain build agents.
The step it fails on is the nuget package restore, it will log some nuget package can't be found.
We're using the TeamCity nuget feed as well as the official nuget feed, the build configuration is attached as a screenshot.

This is a little extract of such a build log:

[18:09:22][Step 1/2] restore: Restoring NuGet packages for xxxxxxxx.sln (12s)

[18:09:22][restore] NuGet command: C:\BuildAgent\plugins\nuget-agent\bin\JetBrains.TeamCity.NuGetRunner.exe C:\BuildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe restore C:\BuildAgent\work\d62df5aff8263242\xxxxxxxxx.sln -NoCache -Source http://teamcity/guestAuth/app/nuget/v1/FeedService.svc -Source https://www.nuget.org/api/v2/

[18:09:31][restore] Successfully installed 'protobuf-net 2.0.0.621'.

[18:09:31][restore] Successfully installed 'Rx-Main 2.2.5'.

[18:09:31][restore] Successfully installed 'Topshelf 3.1.4'.

[18:09:31][restore] Successfully installed 'Rx-Interfaces 2.2.5'.

[18:09:33][restore] Successfully installed 'Rx-Linq 2.2.5'.

[18:09:33][restore] Successfully installed 'Rx-PlatformServices 2.2.5'.

[18:09:34][restore] Successfully installed 'Rx-Core 2.2.5'.

[18:09:34][restore] The remote server returned an error: (404) Not Found.

[18:09:34][restore] Process exited with code 1

[18:09:34][Step 1/2] Step Restore NuGet packages (NuGet Installer) failed


It's not really clear which package it's not finding but if it works on 1 build agent it should be able to retrieve it for the other build agents too ?
We have set the -NoCache option in the configuration but no luck on that one.

Any idea's ?



Attachment(s):
nugetRestore.jpg
1 comment
Comment actions Permalink

If we change the order of the package sources it does seem to work.

So instead of:
%teamcity.nuget.feed.server%
https://www.nuget.org/api/v2/

we used:
https://www.nuget.org/api/v2/
%teamcity.nuget.feed.server%

0

Please sign in to leave a comment.