How can I specify path to jtl files when I want to publish graph (from jmeter-graph-maven-plugin) in teamcity?

I use jmeter-maven-plugin (version 1.10.0) to run JMeter test - first I run it from IntelliJ, then from TeamCity (for both - command: mvn jmeter-graph:create-graph)
When I want to use the following configuration for jmeter-graph-maven-plugin:

<plugin>
    <groupId>de.codecentric</groupId>
    <artifactId>jmeter-graph-maven-plugin</artifactId>
    <version>0.1.0</version>
    <configuration>                           
        <inputFile>${project.build.directory}/jmeter/results/*.jtl</inputFile>
        <graphs>
            <graph>
                 <pluginType>TransactionsPerSecond</pluginType>
                 <outputFile>${project.build.directory}/jmeter/results/TPS.png</outputFile>
            </graph>
        </graphs>
    </configuration>
</plugin>


it works from IntelliJ, but in TeamCity I get:

ERROR: java.lang.IllegalArgumentException: Cannot find specified JTL file: /project/XX/opt/team-city-8.0.5/buildAgent/work/xxxxx/JMeter/target/jmeter/results/*.jtl

Result file exists (and it is previous used in xml-maven-plugin - even configuration is *.jtl - xml plugin works correctly in TeamCity).
When I use specific file name (so e.g. 20150317test-result.jtl instead of *.jtl) it works also from TeamCity. How can I use general file name?

1 comment
Comment actions Permalink

Hi Justyna,

Could you try to run the build from the command line on the same machine as TeamCity agent and with all the same settings? Please follow all the steps described in this guideline and provide requested information.

0

Please sign in to leave a comment.