Server's agent id do not match my agent id

I'm trying to install a build agent on a mac os x machine that was formerly running a build agent on windows running in parallels.  I get this error in the logs during startup:
WARN -    jetbrains.buildServer.AGENT - Server's agent id 93 do not match my agent id 92

How can I fix this?

I tried clearing out the authorizationToken and reinstalling the agent completely, but neither seems to work.

3 comments
Comment actions Permalink

Hi Mark,

Values for the name and ownPort properties of the agent should be unique. Did you remove the old windows agent from the server (on Agent > Agent summary tab)?
Do you have only one agent installed on the new machine?

0
Comment actions Permalink

Yes, I did remove the old agent from TeamCity and stopped the vm that was running it.

In the logs I see:

[2015-04-15 10:30:18,783]   INFO -    jetbrains.buildServer.AGENT - Updating agent parameters on the server: AgentDetails{Name='senchamd-macosx-1', AgentId=92, BuildId=null, AgentOwnAddress='50.242.228.246', AlternativeAddresses=[192.168.1.201, 10.211.55.2, 10.37.129.2], Port=9092, Version='27692', PluginsVersion='27692-md5-66b3d6ba7a8a6d4ad40e06c0e09f39ae', AvailableRunners=[Ant, Duplicator, gradle-runner, Inspection, Ipr, JPS, Maven2, rake-runner, simpleRunner, Xcode], AvailableVcs=[cvs, jetbrains.git, mercurial, svn, perforce], AuthorizationToken='0e48faa6e5fdcd4b55584d9f17ca1e5b'}

and then after about a minute:


[2015-04-15 10:31:33,222]   WARN -    jetbrains.buildServer.AGENT - Server's agent id 93 does not match my agent id 92

0
Comment actions Permalink

Do you have only one agent running on new machine? You can check it using "ps -A | grep java" command. What TeamCity version do you use?
Can the agent connect to the server if you change agent's ownPort parameter?

Do you use HTTP proxy server (Apache/Nginx) in front of TeamCity server? If yes, then please review the Tomcat settings.

0

Please sign in to leave a comment.