Rake Runner Update Breaks Puppet on Ubuntu 12.04

The update from Rake Runner installs Puppet 4.0 (via gems).  Puppet 4.0 requires Ruby 1.9.3.  So on Ubuntu 12.04, Puppet 4.0 does not work.  This also breaks the puppet agent running as a system service (installed through the package management) as the gem version of puppet overrides the package version.

Review:
Rake Runner breaks puppet for both the system and the teamcity agent use.

Please Fix

2 comments
Comment actions Permalink

Specifying the specific version of puppet fixes the issue (first have to remove puppet 4.0 via the following command)
```
sudo gem uninstall puppet
```

In the gemfile, specifying the specific version fixed it.
```
puppetversion = '3.7.5'
```

0
Comment actions Permalink

Hi Michael,

Please see answer in issue comment.

0

Please sign in to leave a comment.