Issue deploying package from Octopus...

Hi all,
       I am pretty new to the automated build process stuff so forgive my ignorance in advance.  Basically we have an issue we are trying to resolve which relates to our build/deployment process.

The specific issue we are getting is when we try to create a release in octopus. The error reads"There was a problem processing your request: 400 Package does not contain a manifest'. We are then unable to select any versions from the drop down menu in octopus that we can normally select. Does anyone know what the issue might be? The package is being created in Team City Professional Version 7.0.3 (build 21424). Although the error is occuring in Ocopus we beleive it might be n issue with the package generation... hence the question here. Some things to note:

- The package seems to generate fine in Team City. Team city then drops the package to a local feed (local folder on the server)
- once the file is dropped in to the local feed location we create a release using Octopus whcih feeds from that location.
- THe package opens fine in Nuget package explorer (whcih indicates that the manifest and files seem to be ok).
- The permissions on the drop folder seem to be correct.
- we have created other releases for other sites using the exact same process however it seems to be one particular site that is causing this error
- We have tried deleting all the packages in the local feed location and starting a fresh build. still the same manifest error.

Please if anyone has any suggestions/solutions as to why we are getting this manifest error in octopus it would be greatly appreciated.

Kind Regards

Paul

1 comment
Comment actions Permalink

Hi Paul,

It seems that the .nuspec file is incorrect. Could you please check this file?

0

Please sign in to leave a comment.