Server Url not sticking

Hello, I have a non trivial setup and maybe that's why the Server Url is not working.

My TeamCity 9.0.4 server is running on Windows Server 2008 R2 Datacenter. The TC server is hosted on AWS in a VPC. The TC server also has IIS to host a simple SMTP server.
The TC server is connected to my office via amazon VPC VPN. The VPC and office have different subnets. Everything is working good between the TC server and its dependencies in my office (code repo, share drive, etc). I am trying to change the server url so that it work a little nicer.

The TC server is register to a Active Domain, let's name it mydomain.local
and these are the identifiers for the TC server:
IP: 10.0.0.1
Computer name. ci  (full name would be ci.mydomain.local)

I have an nginx server acting as a reverse proxy in my office for the resources in the amazon vpc.
The nginx server ip is: 192.167.1.15
I have local dns entries pointing to the nginx server. The nginx settings is mapping host name to the appropriate resource in the VPC.
So there is an entry for: ci.company.com pointing to nginx and nginx has that mapped to the TC server.
The setting for TC's server url is ci.company.com.

My problem is when I visit ci.company.com I get redirected to 10.0.0.1. I do get a response on the first request to ci.company.com, and the response redirects me to 10.0.0.1
If I browse to ci.mydomain.local, this host will stick.

Can you please help me get ci.company.com to stick?
Thank you.

2 comments
Comment actions Permalink

Hello,

Have you configured Nginx proxy server as described in this documentation section: https://confluence.jetbrains.com/display/TCD9/How+To...#HowTo...-Nginx?

0
Comment actions Permalink

Thank you! It works now.
I had those configurations added but with incorrect values.

0

Please sign in to leave a comment.