Suitable build configurations with non-manual VCS checkout mode in which you have permissions to start the builds were not found for the specified changes.

When try to perform Remote Run in TeamCity using plugin in WebStorm the error apear:

Suitable build configurations with non-manual VCS checkout mode in which you have permissions to start the builds were not found for the specified changes.



Attachment(s):
teamcity.png
12 comments
Comment actions Permalink

Hi Alina,
The issue is still present.
I want ask if TeamCity plugin for WebStorm support Remote Run for TFS?
Looks like TeamCity does not return any of suitable build configurations for WebStorm Remote Run.



Attachment(s):
suitableConfiguration.png
1
Comment actions Permalink

Here is the feature reqeust in our tracker: https://youtrack.jetbrains.com/issue/TW-8013. Please vote for it.

0
Comment actions Permalink

Thanks for quick response,
I wonder why this feature (Remote Run) available in TeamCity plugin (see screenshot).
And why "Suitable build configurations with non-manual VCS checkout mode in which you have permissions to start the builds were not found for the specified changes" message showing when you perform Remote Run.
This is very confused.
Something like "Remote Run to TFS does not support by your IDE" will be much more user friendly. And also it will save time for developers and Jetbrains support team.



Attachment(s):
RemoteRun.png
Message.png
0
Comment actions Permalink

And Thanks for create feature request in your tracker.
Can I ask You about specifing IDE for this issue. In our case it is WebStorm not IDEA.
Thank You

0
Comment actions Permalink

Thank you for your feedback and sorry for the inconvenience. I found the related ticket https://youtrack.jetbrains.com/issue/TW-17480 and reopened it, please vote.
This TeamCity plugin provides TeamCity integration for IntelliJ Platfrom-based IDEs. These include IntelliJ IDEA, RubyMine, PhpStorm, WebStorm and others. So actually there is no need to specify the IDE.

0
Comment actions Permalink

Hello,

 

I get the same error when trying to remote run in a scala project

I use IJ community 2016.2.2 and TeamCity Enterprise 9.1.6 (build 37459).

 

Thanks.

 

0
Comment actions Permalink

Hello Yehoram,

What VCS type do you use? Please check that this VCS type is supported and then investigate the case using the guidelines.

0
Comment actions Permalink

Now also seeing this for

git version 2.17.1

IntelliJ IDEA 2019.1.3 (Ultimate Edition)
Build #IU-191.7479.19, built on May 28, 2019
Subscription is active until November 17, 2019
JRE: 1.8.0_202-release-1483-b58 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.15.0-54-generic

TeamCity Professional 2019.1.1 (build 66192)

I get the message without being given any display of existing builds or any options to choose after these 3 clicks...

Team City > Remote Run... > [Remote Run in TeamCity]

The general sense (that it's not finding what it needs) is clear but I have no idea what the detail of the message means

"Suitable build configurations with non-manual VCS checkout mode in which you have permissions to start the builds were not found for the specified changes."

"Suitable" is a useless word because you haven't told me what your definition of suitable is

"non-manual VCS checkout mode" - that phrase probably means something to the dev who wrote it but I have no idea if that's a setting, or something intrinsic to git as a VCS, or if there's anyway to solve that.

"in which you have permissions"  -  I'm using the administrator account so if I don't have permissions, nobody does? You shouldn't mention permissions if it's not clearly the problem.

"for the specified changes" -  I have no idea how you match up changes with builds. Nor does this message help me find out.

So if someone at JetBrains could translate this from JetBrainglese to English that might be a good start.

0
Comment actions Permalink

Hi Gus,

 

thanks for the message, I'll do my best at translating:

"Suitable": Matches all the requirements.

"non-manual VCS checkout mode": In the VCS Settings for your build configurations, there is an option called "VCS checkout mode", which contains an option to "Do not check out files automatically". This is manual VCS Checkout mode, and is not supported for personal builds.

"in which you have permissions": Agreed, useless bit of information if the user is running as an administrator.

"for the specified changes": The VCS configuration in TeamCity have a URL (or path) where they pick up the changes from. They need to match that of the VCS you have defined in your project in IDEA, either locally (if it's a path) or on the remotes. Your changes (uncommitted) only make sense in the context of a repository that holds the same revision you are working on, so TeamCity will try to match it via this bits of information.

 

We have a request to improve this error message already: https://youtrack.jetbrains.com/issue/TW-52873, although I'm afraid this one is private and you won't be able to see its progress, you can use it as a reference if you need an update. There is also a request to improve the diagnostics on it: https://youtrack.jetbrains.com/issue/TW-22667

0
Comment actions Permalink

Hello,

 

We are having the same issue in Rider. Because we cannot use remote run from Rider, most of our team have ditched Rider, and gone back to Visual Studio, while we who still use Rider have to use Visual Studio to perform the remote runs (which is quite annoying).

Now with Rider v.2020.1 I was hoping it would work, but no.I'm guessing there must be some setting we're not seeing, either in Rider or TeamCity which is causing this. The problem is that we have no clue what setting to look for. The fact that everything works from Visual Studio leads me to believe it's in Rider we need to look...

Any help would be greatly appreciated!

0

Please sign in to leave a comment.