Errors in maintainDB backup log since upgrade to TeamCity 9.1

We recently updated to TeamCity 9.1. We've had a scheduled nightly backup in place using "maintainDB backup" for some time which has never had a problem. Now since the upgrade we're seeing the following error messages being output from the backup process:

Exporting TeamCity data directory: Exporting build logs
File has disappeared in stage BuildLogs. File: "C:/Users/Administrator/.BuildServer/system/artifacts/ProjectX/01 Build/104423/.teamcity/logs/buildLog.msg5"
File has disappeared in stage BuildLogs. File: "C:/Users/Administrator/.BuildServer/system/artifacts/ProjectX/01 Build/104423/.teamcity/logs/buildLog.msg5.i1"

...

There are 2,058 such error messages in the log.

Is this a bug in TeamCity 9.1?

8 comments
Comment actions Permalink

Hi Chris,

Do the backup finished successfully?
I've created the ticket in our tracker https://youtrack.jetbrains.com/issue/TW-41874, please watch/vote for it.

0
Comment actions Permalink

Hi Alina,

The maintainDB output finishes with the following messages:

Export has completed successfully.
...
Backup finished with warnings. See log files for details.

However the resulting Zip file has dropped in size from consistently being around 170MB to only being around 16MB. It's clear therefore that a major element of the data being backed up (the build logs I assume) is missing.

Thanks,
Chris

0
Comment actions Permalink

Chris, what version did you use before?

0
Comment actions Permalink

Hi Pavel,

I generally upgrade each time a new version is available. The upgrade path has been:

...
8.1.5
9.0.1
9.0.2
9.0.3
9.0.4
9.0.5
9.1

Regards,
Chris

0
Comment actions Permalink

To me it looks like the problem was introduced somewhere around 9.0.2. Can you confirm it?

0
Comment actions Permalink

Hi Pavel,

I've looked back at my backup log files and the dates upgrades were installed and from what I can see the problem was introduced following the upgrade from 9.0.5 to 9.1.

I hope that helps.

Regards,
Chris

0
Comment actions Permalink

Fixed in TeamCity 9.1.1.

0
Comment actions Permalink

This issue has been resolved since above (ver 9.1.1, 6 Aug 2015) but reared its head again yesterday?

The same TeamCity instance is now latest version 2017.1.4 upgraded 8 Sep 2017.

Just yesterday I started getting messages like the following in the maintainDB log file (from nightly scheduled backup):

File has disappeared in stage BuildLogs. File: "C:/ProgramData/JetBrains/TeamCity/system/artifacts/ProjectX/1 Build/190862/.teamcity/logs/buildLog.msg5"
File has disappeared in stage BuildLogs. File: "C:/ProgramData/JetBrains/TeamCity/system/artifacts/ProjectX/1 Build/190847/.teamcity/logs/buildLog.msg5.i1"

Any ideas on why this problem has suddenly resurfaced?

0

Please sign in to leave a comment.