SSH MERCURIAL and TEAMCITY v8.1.4

Hi,
After a painful day of trying to get my mercurial repo to work with SSH, i have finally decided to ask the the community. I have followed this tutorial to the tee
http://hmemcpy.com/2010/09/configuring-mercurial-hg-with-teamcity-over-ssh-at-repositoryhosting/

and i combined this solution as

http://blog.chudinov.net/how-to-integrate-teamcity-with-remote-mercurial-repo-through-ssh/

What in the hell does this error message mean?
"Test connection failed in plutora :: USA Support [plutora.com] Web Site Build. '"C:\Program Files\TortoiseHg" --config ui.interactive=False identify ssh://hg@bitbucket.org/plutora/portal' command failed."

What is config ui.interactive= false exactly?.

Also why is that when i added my ssh key in the accounts page it says it is not in use.

Please for the love of automation make a error code make sense! or give detail!!!!.

I have setup tortoise correctly i can even pull locally and push locally using the key that putty gen made for me but for no reason at all teamcity does not like my configuration.
any ideas, guide, tutorial, information and logical steps to finding out how to fix this is greatly appreciated and will be well recieved and valued.
This is causing a COMPLETE STOP TO PRODUCTIVITY IN THE OFFICE. We can not use https because we have exceeded our topological headvisions so no more pulling or merging with out losing previous dev auditing being removed. I need to work with ssh.

Thanks again.



Attachment(s):
Screen Shot 2014-07-24 at 5.12.22 pm.png
Screen Shot 2014-07-24 at 5.16.27 pm.png
5 comments
Comment actions Permalink

Hi,

Could you please try to change HG command path to C:\Program Files\TortoiseHg\hg.exe?

0
Comment actions Permalink

Yes I have tried that. Is there a way to get live support from team city with a Skype session. This is causing as a lot of issues with productivity.

0
Comment actions Permalink

Ok ive have gotten ssh to connect with the message "Test connection successfull"
however it seems to be hanging on "checking for changes".

0
Comment actions Permalink

We do not provide online support. Please read this section for more information.

0
Comment actions Permalink

How did you acheive a sucessfull connection?  I am having a problem getting this to work too.

0

Please sign in to leave a comment.