How to setup build agent Configuration Parameters?

Hi. I am setting up a build agent. I've been using team city for a while and I have another build agent to copy from, but I have not been able to figure out this issue.

The build agent is being installed under MacOS X and will be used to build a Mac app using Xcode.

I downloaded and installed Xcode. The version I installed is 7.0. I have verified that xcodebuild works.

I downloaded "buildAgent.zip" and unzipped it in my home directory. I copied the file buildAgent.dist.properties and named the new version of the file "buildAgent.properties". Then I modified the new buildAgent.properties file and set the serverUrl to be our teamcity server and set a name for the new build machine. Then I saved the changes.

Next in the Terminal, I ran "agent.sh start" to start the agent.

Then on the team city web page, I saw the new agent appear in the list of agents. Then I asked our system administrator to authorize the new agent. Once it was authorized, I looked at my project settings under "Compatible Agents". For this build machine, I see "Unmet requirements" listed as:

tools.xcode.home exists
and

tools.xcode.version.major is not less than 4


Then I take a look at the "Agents" tab. Under this tab I see that my new build agent does not have any of the values set for "tools.xcode.XXX". The old build agent has several settings labeled "tools.xcode.XXX". However, I have looked and so far I have been unable to find anything about how these things should be set.

The version of TeamCity is TeamCity Enterprise 8.1.1 (build 29939). I have tried running grep on the entire filesystem looking for "tools.xcode" and I haven't found anything.

Any suggestions as to how this can be addressed would be appreciated.

Thank you.

4 comments
Comment actions Permalink

I was able to solve this. The solution was to revert to Xcode 6.4. The problem was that team city's xcode build runner was accessing and relying on private undocumented files distributed within the Xcode.app bundle. My organization is using an older version of team city (8.x), so perhaps this problem was addressed in a later version of team city.

0
Comment actions Permalink

Hi Brant,

XCode 7 is supported in not supported by TeamCity 8.x version. Please consider updating TeamCity to latest version (9.1.2 at the moment).
Please find more details here: https://confluence.jetbrains.com/display/TCD9/Xcode+Project#XcodeProject-Xcode7Support.

0
Comment actions Permalink

I am seeing a similar problem in TeamCity Professional 10.0.5 (build 42677).  Once I updated my build agents to Xcode to 10.1, my build agents are reporting:

Unmet requirements:  

  • tools.xcode.version.major is not less than 4

I did not have problems with Xcode 10.

0
Comment actions Permalink

I figured out what was going wrong.  To solve this problem, I ran `xcode-select --install` to force command-line build tool (re) installation (even though Xcode 10.1 reported that it already did this).  I then restarted the build agent.  This seemed to work for one of the two build agents (investigating what is going on with the second at the moment).

0

Please sign in to leave a comment.