Unable to start Teamcity Service 9.1.1

Hi I have installed Teamcity server 9.1.1, it has been installed properly but I am unable to start the service form service.
When I click start, it shows running and immediately is shows stopped.
Previously I installed the same version of teamcity 9.1.1 and it was running. Now I do not know what happened when I installed in Windows Server 2012 R2

Here is some log I found.

[2015-10-06 12:39:44,374] ThreadedServiceTask               [Info] CallStartService
[2015-10-06 12:39:44,374] FileTaskSettings                  [Info] Parsing service settings
[2015-10-06 12:39:44,374] FileTaskSettings                  [Info] Program to execute:   C:\Windows\system32\cmd.exe
[2015-10-06 12:39:44,374] FileTaskSettings                  [Info] Program arguments:    /c teamcity-server.bat run service
[2015-10-06 12:39:44,374] FileTaskSettings                  [Info] Program work dir:     c:\TeamCity\bin
[2015-10-06 12:39:44,374] FileTaskSettings                  [Info] Program stop timeout: 900000
[2015-10-06 12:39:44,405] ProcessCommand                    [Info] Process exited with code: 255
[2015-10-06 12:39:44,499] console                           [Info] Looking for installed Java...
[2015-10-06 12:39:44,499] console                           [Info] Java executable is found: 'c:\TeamCity\bin\..\jre\bin\java.exe'.
[2015-10-06 12:39:44,499] console                           [Info] '127.*' is not recognized as an internal or external command,
[2015-10-06 12:39:44,499] console                           [Info] operable program or batch file.
[2015-10-06 12:39:44,499] ServiceExecuteProcessTask        [Error] Service process exited without service stop request


Kindly help.

Thank you

3 comments
Comment actions Permalink

Hello,

Could you please check what is the value of JAVA_OPTS parameter?

0
Comment actions Permalink

Hi I already removed the qoutes for JAVA_OPTS in catalina.config

:noJuliConfig
set JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG%

if not "%LOGGING_MANAGER%" == "" goto noJuliManager
set LOGGING_MANAGER=-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
:noJuliManager
set JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER%

0
Comment actions Permalink

Did it help to solve the issue?

0

Please sign in to leave a comment.