svn: E175002: connection refused by the server

We're looking into moving our source control from SourceSafe (yes, seriously) to TeamForge and I'm trying to connect TeamCity to TeamForge (collab.net) but Test Connection is failing with:

Error connecting the specified URL:
svn: E175002: connection refused by the server
svn: E175002: OPTIONS request failed on '/'


I've been googling on and off for the last few days and tried various things such as:

-Dsvnkit.http.sslProtocols=SSLv3
-Djsse.enableSNIExtension=false


and today updated to 9.1.5 (Java version: 1.8.0_66) but still fall at the first hurdle.

For info, TeamCity is behind a corporate proxy server where both TeamCity services run as a domain user that can get through the proxy (got this working for NuGet restore).

Can anyone help me figure out what the problem may be?

1 comment

I have discovered that svnkit uses its own proxy settings: proxy settings for subversion

> By default SVNKit uses proxy settings from the servers configuration file that is located in the default SVN run-time configuration area.
>
> Default configuration area is located at ~/.subversion on Linux and OS X and at C:\Documents and Settings\userName\Application Data\Subversion on Windows.

When creating a VCS Root to Subversion, TeamCity offers a couple of settings under SVN Connection Settings, a checkbox Default config directory and a text box Configuration directory.

I unchecked default directory and pointed the Configuration Directory to the directory created as described below.

- Create a folder within TeamCity: C:\TeamCity\conf\Subversion
- Create a file in this folder named servers (no extension) with the following content:

    http-proxy-host = proxy.xyz.abc
    http-proxy-port = 80

0

Please sign in to leave a comment.