Web UI for custom trigger not working

Answered

I have a custom trigger plugin that I've been using for years. It has a jsp page to configure it. It was written by someone who is no longer with our company, but I have the source. We upgraded to TC9 from TC7 last year. Recently, I tried to change the name of the folder the jsp file is in because it was spelled wrong. This caused the plugin to stop working. Even after changing the name back, it still won't work. I have tried various things to get it back to what it was with no luck.

I have even tried to create a copy of it with a different name. In both cases, they show up on the Plugins List page, so it appears to have loaded the plugin, but when I try to add a new trigger to a build configuration, neither one are in the list. If I go to a configuration that was using the original plugin, it says, "unknown build trigger" and when I click the Edit button, it says, "The corresponding plugin is not loaded".

I have my plugin in the <TeamCity Data Directory>/plugins folder and the jsp page in <TeamCity Web Application>/webapps/ROOT/plugins. I noticed that there is also a folder related to my jsp file in <TeamCity Web Application>\work\Catalina\localhost\_\TC_37293_DrmsTestrigger. This folder contains a bunch of subfolders and a java/class file with the same name as my jsp file. However, the folder for my copied version is empty.

As far as I know, the plugin itself is fine; I just think I'm missing a step in deploying it. I have no idea why the original no longer works. Any advice would be appreciated.

 

1 comment

The jar file was rebuilt wrong. I was able to get the old plugin working again by restoring a backup.

0

Please sign in to leave a comment.