Build is not being triggered by VCS (Subversion) commit

Hello,

I am using TeamCity 4.5.4 (Build 9071) on a Windows Server 2003 32Bit machine.  I have a Subversion repository on another Windows machine.  All of my projects are building from the same root (I have about 450 configurations).  My root VCS looks like this:

http://mysvnrepo.com/base/trunk

Each of my configurations has checkout rules that look like this:

+:./foo=>foo

The projects have the box checked to be triggered when there is a change.  TeamCity recognizes there are changes.  Next to each configuration there is "Idle Pending (2)".  I can look at the pending changes right there.  There are idle agents that are compatible with the configurations.  I can manually kick off the build and it runs, including building the dependencies.  The problem is TeamCity does not automatically kick off the builds.  TC used to and then it just stopped.  Help?  Thanks!

8 comments
Comment actions Permalink

Hello David,

  Could you please check your build triggering rules, do you have any? May be you filter out changes by some paths, or changes made by particular user?
  Please provide screenshots of your VCS build trigger page, VCS settings.

  Please also change the following section in conf/teamcity-server-log4j.xml file to enable debug logging:
  From:
<category name="jetbrains.buildServer.buildTriggers.vcs" additivity="false">
    <appender-ref ref="ROLL.VCS"/>
    <appender-ref ref="CONSOLE-ERROR"/>
  </category>

  To:

<category name="jetbrains.buildServer.buildTriggers.vcs" additivity="false">
     <priority value="DEBUG"/>
    <appender-ref ref="ROLL.VCS"/>
     <appender-ref ref="CONSOLE-ERROR"/>
   </category>

  Than, remove logs/teamcity-vcs.log, restart TeamCity, make the change, ensure TeamCity detects it and doesn't start the build.

  After that please send us logs/teamcity-vcs.log.

  Thanks and sorry for delay with reply.

  Kind regards,
  KIR

0
Comment actions Permalink

Thank you for getting back to me.  I have grabbed the screenshots you asked for (hopefully all of them!) and attached the log file too.  I've replaced project names with project1, project2, etc but the format is still the same.

After looking at the log file I think I know what is going on.  I get this warning message:

[2009-09-21 10:26:06,366]   WARN [hanges loader 2] -      jetbrains.buildServer.VCS - [Project7 :: Solaris 5.10 - Debug] Too much builds in the queue (113), will not trigger more builds. You can override this behaviour by specifying server system property -Dteamcity.vcsTrigger.maxBuildsInQueueThreshold=N (0 to disable limit)

Currently I am going to try setting this property to 0 and see if that helps.  I am interested to hear what you think.  Thanks!



Attachment(s):
TriggerSettings.JPG
VCS_Settings.JPG
Pending_No_Building.JPG
0
Comment actions Permalink

Hello David,

  Removing the build queue limit is not a good idea - this may affect performance of the server.

  The question is why builds from the queue are not started. Please to to the build queue and view the reason of that.
  If there is "No agent" link it will lead to the page which explains why build cannot be started.

  BTW, I don't see the attached log to the post.

  Regards,
  KIR

0
Comment actions Permalink

Oops Sorry!  Here is the log.  Yes there were 113 items in the queue.  Considering we have 100's (close to 500 at this point) configurations, going over 100 is rather low for us.



Attachment(s):
teamcity-vcs.log.zip
0
Comment actions Permalink

Hello David,

   The question is why there are no running builds when you have 13 available build agents. If this is not a problem for you (for instance, if a capable build agent for queued builds is disconnected by the moment)), you should really go with adding system property.

  Regards,
  KIR

0
Comment actions Permalink

A very valid question.  The 13 agents I have are 4 Windows machines and 9 Unix/Linux machines (each Unix/Linux machine is a different platform).  One of the Unix machines was running out of space (and therefore failing all builds) so I disabled it.  While it was disabled, the queue built up with builds for that Unix machine.  When those reached the limit, the Windows and other Unix/Linux builds would not be added to the queue.

By the way, after I defined that Java variable to 0, everything started working again.  It really was just due to the build queue limit being plugged up.

0
Comment actions Permalink

OK, now everything is clear.
Good luck with your builds  

Regards,
KIR

0
Comment actions Permalink

Thank you for your help.  It was very much appreciated!

Just a comment from a TeamCity user, it might be a good idea to mention the queue limit in the documentation.

0

Please sign in to leave a comment.