Set up issue

I am attempting to set up teamserver. I have pointed it to our perforce server and the connection test works OK. I get this meesage back attempting to build:

WARN - dTriggers.vcs.VcsChangesLoader - Cannot evaluate current version:
jetbrains.buildServer.vcs.VcsException: Perforce 'chanegs' returns empty string
at jetbrains.buildServer.buildTriggers.vcs.perforce.PerforceConnection.getCurrentVersion(PerforceConnection.java
:232)
at jetbrains.buildServer.buildTriggers.vcs.perforce.PerforceSupport.getCurrentVersion(PerforceSupport.java:122)
at jetbrains.buildServer.buildTriggers.vcs.VcsChangesLoader.loadChanges(VcsChangesLoader.java:37)
at jetbrains.buildServer.serverSide.impl.ProjectImpl.loadChanges(ProjectImpl.java:259)
at jetbrains.buildServer.serverSide.impl.ProjectImpl.checkForModifications(ProjectImpl.java:269)
at jetbrains.buildServer.serverSide.impl.BuildServerImpl.checkForModifications(BuildServerImpl.java:1207)
at jetbrains.buildServer.serverSide.impl.BuildServerRunner$2.doSomething(BuildServerRunner.java:51)
at jetbrains.buildServer.serverSide.impl.BuildServerRunner$BuildServerWorker.run(BuildServerRunner.java:92)
at java.lang.Thread.run(Thread.java:595)

3 comments
Comment actions Permalink

Could you please try to call
p4 -P %passwd% -c %client-name% -u %user-name% -p %port% changes -m 1
on server. What is the server response?
Thanks!

"Gary Evesson" <gary@decentrix.com> wrote in message
news:10402358.1152117405285.JavaMail.itn@is.intellij.net...
>I am attempting to set up teamserver. I have pointed it to our perforce
>server and the connection test works OK. I get this meesage back attempting
>to build:
>

WARN - dTriggers.vcs.VcsChangesLoader - Cannot evaluate
current version:
jetbrains.buildServer.vcs.VcsException: Perforce 'chanegs' returns empty
string
at
jetbrains.buildServer.buildTriggers.vcs.perforce.PerforceConnection.getCurrentVersion(PerforceConnection.java
:232)
at
jetbrains.buildServer.buildTriggers.vcs.perforce.PerforceSupport.getCurrentVersion(PerforceSupport.java:122)
at
jetbrains.buildServer.buildTriggers.vcs.VcsChangesLoader.loadChanges(VcsChangesLoader.java:37)
at
jetbrains.buildServer.serverSide.impl.ProjectImpl.loadChanges(ProjectImpl.java:259)
at
jetbrains.buildServer.serverSide.impl.ProjectImpl.checkForModifications(ProjectImpl.java:269)
at
jetbrains.buildServer.serverSide.impl.BuildServerImpl.checkForModifications(BuildServerImpl.java:1207)
at
jetbrains.buildServer.serverSide.impl.BuildServerRunner$2.doSomething(BuildServerRunner.java:51)
at
jetbrains.buildServer.serverSide.impl.BuildServerRunner$BuildServerWorker.run(BuildServerRunner.java:92)
at java.lang.Thread.run(Thread.java:595)



0
Comment actions Permalink

Found my problem. I did not set up the perforce depot spec correctly (left off the /... on the end).

0
Comment actions Permalink

Fine!
Thanks for the response
"Gary Evesson" <gary@decentrix.com> wrote in message
news:32166438.1152724411843.JavaMail.javamailuser@localhost...

Found my problem. I did not set up the perforce depot spec correctly (left
off the /... on the end).



0

Please sign in to leave a comment.