TeamCity, build 1574 is available

In this build:

Features

  • TW-448 Automatically place failed build in build queue

  • TW-670 Option to mark build failed if there is at least one failed

test

  • TW-248 Allow e-mail configuration and jabber configuration from web

page

  • TW-579 Avoid starting build immediately after VCS changes are detected

(allow to set quiet period)

  • TW-203 Build execution timeout

  • TW-632 Schedule-based build trigger: Add option to skip build without

any changes

  • TW-666 "Jump to" combobox on the History page

  • TW-699 Location of .BuildServer directory should be easily overridden

  • TW-730 Need to be able to use different from-address - not

build-server@intellij.net

  • TW-707 Support NUnit tests for MSBuild (solution 2005) runner

  • TW-667 Support VCS ignore list

  • TW-709 Fixed URL for latest build of a selected build configuration


Bugs

  • TW-629 "cvs server: invalid option - S" when trying to do a cvs

checkout

  • TW-534 CVS Settings - Test Connection reports "Connection Failed" when

there are innocent warnings

  • TW-740 SVN checkout should honor subversion config file or allow

configuration

  • TW-721 Updated sources results in Jar and Zip files returning "invalid

CEN header"

  • "Success" is shown instead of number of passed tests

  • more fixes


If you are going to upgrade from previous build of TeamCity please do not
remove license.keys file from the .BuildServer directory.

--
Pavel Sher
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


3 comments
Comment actions Permalink

I was unable to get this build working from scratch or with a clean database. I could not create an admin user in either case. This was using mysql. I had to revert back to the full previous release and database.

And yes, I did move the old license back into place and I still couldn't use or create an admin user.

--Tim

0
Comment actions Permalink

Hello Tim,

At the moment we cannot reproduce the problem, could you please send us logs
produced by server? BTW did you copy mysql driver into the WEB-INF/lib
directory before server startup?

--
Pavel Sher

"Tim McNerney" <intellij@oneofus.org> wrote in message
news:13127400.1156980651960.JavaMail.itn@is.intellij.net...
>I was unable to get this build working from scratch or with a clean
>database. I could not create an admin user in either case. This was using
>mysql. I had to revert back to the full previous release and database.
>

And yes, I did move the old license back into place and I still couldn't
use or create an admin user.

>

--Tim



0
Comment actions Permalink

When I tried again this morning, I was unable to reproduce the problem I was seeing yesterday. Either I was dreaming or the bug only appears on Wednesday's.

--Tim

0

Please sign in to leave a comment.